1

Earlier today I could copy/paste text from a windows text file into a cmd shell on brand new Raspberry Pi 4 running WiFi headless, accessed using VNCviewer.

After apt update, apg full-upgrade then reboot, this no longer works, like after the update, the Raspberry Pi 4 clipboard doesn't get the text whereas it did before the update.

I am using Windows 7 to VNCviewer (VNC-Viewer-5.3.2-Windows-64bit) to Raspberry Pi 4 that Raspbian Buster is running.

It still works fine for my Raspberry Pi 3. I need a clue.

6
  • The last VNC Viewer is : VNC-Viewer-6.19.1115-Windows.exe. You can take a look here maybe – Ephemeral Jan 4 '20 at 20:49
  • Thanks @Ephemeral... got excited.. tried all of the suggestions in link (one at a time, etc.) but unfortunately none worked. Sad thing was that copy/paste worked this AM, before doing updates. Sigh. – JamesRPI4200104 Jan 4 '20 at 21:19
  • Also on your desktop on the top bar you have the VNC icon , right click on it and go to Options and on the left you have in the menu Users and Auths... ensure you have the checkbox Copy-paste text in both directions checked for Globals Auths. (sorry i'm not english maybe your menu names differ). The menu where you can find Options – Ephemeral Jan 4 '20 at 21:41
  • Thanks again @Ephemeral. I had already checked the VNC options, Copy/Paste was enabled. Tried VNC-Viewer-6.19.1115 = same problem. – JamesRPI4200104 Jan 6 '20 at 20:03
  • Since the noted update, I had created and was using a new login, without sudo privs. Copy/Paste didn't work. Logged in as root and Copy/Paste worked again, both directions. Created new login with sudo priv and C/P worked both directions. But, even when using root login, I cant C/P from Firefox in windows to FF on Rpi4 or vice-versa. Using RPi-3B+ I can C/P from FF on RPi to FF on Windows but not the reverse. Smelling like a permissions/privledges issue but I am clueless where to look. About to give up... got a bigger issue to handle and it makes no sense either... – JamesRPI4200104 Jan 6 '20 at 20:04
2

As noted in my comment above, I found that copy/paste text to/from windows app from/to RPI4 app works* when the user account is setup with sudo privileges (its not necessary to actually use sudo, just have the login in the sudo group). Works when login as root too. * One exception: C/P to/from Firefox in windows from/to Firefox on RPi4 doesnt work, either direction. Moving on...

1
  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year. – Ingo Jan 12 '20 at 13:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.