I'm new to this website.

So I've just downloaded raspbian onto my Pi, and in the setup process and I ticked a checkbox that said something along the lines of "This resolution doesnt work" by accident. I restarted and the resolution was off. The screen doesn't fit on my monitor. I've tried to fix it, I've looked it up and all I've done is mess it up more. now it's too small. If you could help me that would be awesome thanks.

  • I posted an Answer which should work on the Pi4, but noticed you have tagged this Pi3 - although the Pi3 doesn't allow xrandr to change resolution so you need to be more specific about what you ACTUALLY did. – Milliways Jan 5 '20 at 1:10

Hey welcome to RPi StackExchange!

I hope you at least can see the LXTerminal in your screen. If you can then type sudo raspi-config and highlight Advanced Options with arrow keys and highlight Select with tab key and press Enter. Then do the same process for selecting Resolution menu and switching the resolution. At last, use tab key to select OK and press Enter to change the resolution. You can do the same steps with an SSH connection.

Or, plug in your RPi SD card to another device and edit the file boot/config.txt in your card.

For any other problems, comment here.


Edit the file /boot/config.txt.
Note this can be done by putting the SD-Card in another computer and editing it from there.
For instance, if it is mounted as /media/pi/usbkey/ then you can edit the file /media/pi/usbkey/boot/config.txt.

Don't edit /boot/config.txt as that is the one for the operational computer. The comments therein are quite helpful.


If not using a Pi4 the only way to change resolution is in config.txt and reboot.

This can be done by running sudo raspi-config in the Console then selecting Advanced Options
or editing out the changes in config.txt e.g.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.