0

I have a Pi, running Raspbian 10 Buster. I would like to portforward VNC and transmission. I have opened the ports in my router, firewall. The ports are still "closed". I was trying to see why is this, so what I see if I check my wireless interface's MAC address in terminal, it shows different than the one the router sees. I have no idea how this is possible. I'm looking for help. (By the way I run a VPN client on my Pi.) The port is open on the VPN provider side. I use Windscribe, if that matters.

  • "it shows different than the one the router sees", What if you disable VPN client? Any effects? – M. Rostami Jan 6 at 17:36
  • Unfortunately not. I tried to turn off VPN, firewall, restart network services. The router recognize a different MAC address. I do ifconfig command, wlan0 MAC address isn't matching with the one in the router. – Ryan Jan 6 at 18:59
  • I don't know the model of your router, however, detach RPi form the router and try to clear arp-table of the router anyhow. Next, check the arp-table again. You'll see some devices just added. Attach RPi and ping the RPi address from the router to add the RPi entries. – M. Rostami Jan 6 at 19:06
  • Do you want to connect from outside the internet to your RasPi? What public ip address your router has on the internet? How do you checked that the port on the public ip address is closed? I do not understand this issue with the mac address. What has it to do with port forwarding? Please address me with @Ingo, otherwise I won't see your reply. – Ingo Jan 7 at 19:29
  • @Ingo I would want to connect to my Rpi through the internet. It's just a weird thing that the mac addresses are different. – Ryan Jan 8 at 1:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.