1

I have a gps module based on L80-39 chip and a raspberry Pi 3 model B

I connected it initially via USB cable, followed instructions from this site https://wiki.52pi.com/index.php/USB-Port-GPS_Module_SKU:EZ-0048

That is:

sudo apt-get -y install gpsd gpsd-clients python-gps
sudo systemctl enable gpsd.socket
sudo systemctl start gpsd.socket
sudo systemctl restart gpsd.socket
sudo systemctl status gpsd.socket

Status showed that it's active and running. I modified the file in /etc/default/gpsd so it looked like this:

START_DAEMON=true
USBAUTO=true
DEVICES="/dev/ttyUSB0"
GPSD_OPTIONS="-F /var/run/gpsd.sock"

And everything worked fine the gps got a fix for the first time after few minutes sudo cgps -s showed all the info. But i needed PPS and i found that via USB i won't be able to get that so i bought USB to TTL adapter. I connected the module like this:

VCC Red wire

GND Black wire

TXD Green wire

RXD White wire

And USB back to Raspberry.

Changed nothing in the settings and now I'm getting GPS timeout constantly. I don't know what to do now please help.

  • Did you change the DEVICES line to account for the new USB device? – stevieb Jan 9 at 18:46
  • I checked ls /dev and there's nothing new there it's still called ttyUSB0. – Bamse Jan 9 at 18:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.