0

I recently changed my Raspberry Pi 3B setting in dhcpd.conf to set a static private IP address. I've been able to SSH into the pi, as well as ping it. But for some odd reason, when I check my router's list of connected devices, the raspberry pi's static IP doesn't show up. Instead, the old dynamically allocated DHCP IP address is associated with the pi.

Why is that, and how can I change it?

  • "Why is that, and how can I change it?" What did YOU do? – Milliways Jan 11 at 2:14
  • 2
    router's list of connected devices - are you sure this list isn't the list of IP addresses handed out by DHCP? Depending on the DHCP lease time, the old dynamic address could be listed for a long time. Any device with a static IP won't show on the DHCP list – Jaromanda X Jan 11 at 2:22
  • 1
    by the way, the way I give my devices a static IP address is ... the device is set for DHCP (as most default to use DHCP) and set my router to hand out a "reserved" IP address (based on MAC address of device) - therefore, all my devices essentially have a static address, and if I need to change that, or other settings (like DNS servers) I can do so in one place for all my devices – Jaromanda X Jan 11 at 2:24
  • Lease IP address and request to a new IP address by these commands. sudo dhclient -v -r wlan0 then sudo dhclient -v wlan0. – M. Rostami Jan 11 at 14:14
  • You modified dhcpd.conf which is the configuration for the ISC DHCP server. Do you installed this DHCP server and use it in addition to the other DHCP server on your router? This cannot work and will confuse your whole network. – Ingo Jan 12 at 14:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.