1

I am newbie with Raspberry and this is my first time using it.

I downloaded Rasbian Buster Lite and flashed it with Etcher. Added ssh named file to boot directory and also file named wpa_supplicant.conf.

Rasp is connecting to iPhone's hotspot fine no problem, but i can not connect to it with Putty.

In wpa_supplicant.conf file i have this code:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
    ssid="name"
    psk="password"
    key_mgmt=WPA-PSK
}

Of course real name and real password in real file.

I tried to log in with hosts: raspberrypi and raspberrypi.local. Not working. Putty says Unable to open connection to raspberrypi. Host does not exist.

Also tried ipconfig /flushdns which i found from one page, it is not help either.

3
  • Did you get the IP address of the Raspberry Pi by ping raspberrypi.local and put the IP to the PuTTY for connecting over SSH protocol? raspberrypi.stackexchange.com/a/107323/44221 – M. Rostami Jan 16 '20 at 22:03
  • 1
    A hotspot will give the Pi internet access but does not magically turn the iPhone into a router – Milliways Jan 16 '20 at 22:06
  • @Milliways That is true. I dig up my old modem and it worked with that. I used 2G mode, 5G does not work with this Pi. – masteroscar Feb 16 '20 at 14:55
1

Sadly, I think it's quite hit & miss connecting via SSH over iPhone hotspots. See this question: https://apple.stackexchange.com/questions/194842/iphone-is-the-hotspot-isolated-can-you-see-other-devices

Some people have had luck with it, others haven't. I don't know of any official documentation detailing what versions it should/shouldn't work with. If you can, definitely try the same setup with a regular WiFi router.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.