9

I've installed the image ubuntu-19.10.1-preinstalled-server-arm64+raspi3.img.xz on an sd card and am trying to boot ubuntu server for the first time on my raspberry pi 4.

I get to this stage in the boot and it hangs:

ubuntu 19.10 ubuntu tty1

ubuntu login: [...] cloud-init[....] Cloud-init v. 19.2-36-g059d049c-Oubuntu3 running 'modules:config' at ...
[...] cloud-init[....] Cloud-init v. 19.2-36-g059d049c-Oubuntu3 running 'modules:final' at ...
[...] cloud-init[....] Cloud-init v. 19.2-36-g059d049c-Oubuntu3 finished at ...  Datasource DatasourceNoCloud [seed=/dev/mmcblkp01][dsmode=net]

I've seen this question and tried creating the file /boot/firmware/usercfg.txt with total_mem=3072 (the file does not already exist), but it has no effect.

How should I proceed?

EDIT:

After updating /usercfg.txt on the vfat partition I advance to the previous logs, plus:

[  ok  ] Started execute cloud user/final scripts.
[  ok  ] Reached target Cloud-init target.

and I'm hanging once again.

Note there's some noise about ssh keys that I don't remember seeing before, I can give more info on that if necessary.

3
  • "Set total_mem=3072 in /boot/firmware/usercfg.txt. (If you mount the sd card in another computer, the usercfg.txt is on the small vfat partition.)" askubuntu.com/a/1182566/859552
    – M. Rostami
    Jan 18 '20 at 14:28
  • @M.Rostami Thanks for pointing that out, appreciate it. I've advanced slightly further but still remain blocked. The question is updated if you've ever encountered this before. Thanks again.
    – Preston
    Jan 18 '20 at 15:35
  • It seems around the "ACPI Shutdown". Therefore, change the power supply and test it again.
    – M. Rostami
    Jan 26 '20 at 19:27
10

I had the exact same issue on a P3 - tried different ISOs but no joy

I was able to fix by disabling cloud init via ssh.

1) get the IP address of the Pi - I was at home so just logged onto my router and got it from there

2) in windows command line on another machine login using command :

ssh ubuntu@[ip address]

the default password is 'ubuntu'

3) you will be forced to change the password, do this

4) you will then be logged out - log back in using the above and the new password

5) when you get to the UNIX bash prompt run the command

touch /etc/cloud/cloud-init.disabled

6) exit and restart your Pi

hope this helps

3
  • thanks you just saved me a whole lot of trouble :)
    – Heetola
    Mar 23 at 9:15
  • Thanks. This really helped. I had the exact same problem as the OP and this was the exact answer I needed. Jul 19 at 14:19
  • Weird, I can't even get as far as ssh onto mine. They seem to hang before that is available. Sep 6 at 10:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.