0

When compiling some code that I used previously on RPi 3B, I received the message

fatal error: rpc/des_crypt.h: No such file or directory

Found out that this file does exist on RPi3b but not on RPi 4, folder /usr/include/rpc.

I have run apt update and apt full-upgrade. My system now is

Linux rasbap4 4.19.75-v7l+ #1270 SMP Tue Sep 24 18:51:41 BST 2019 armv7l GNU/Linux

My RPi 3B is

Linux tussilago 4.19.66-v7+ #1253 SMP Thu Aug 15 11:49:46 BST 2019 armv7l GNU/Linux

I have tried to find a suitable package with the file. Using apt-file on my ubuntu machine I found that libc6-dev should have des_crypt.h

apt-file -x search '/des_crypt.h$'

I tried to install it on the raspberry, but it says it already has the newest version

$ sudo apt-get install libc6-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libc6-dev is already the newest version (2.28-10+rpi1).
libc6-dev set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

On my RPi3b, the version is older and not rpi1 (what does that mean?):

$ apt-cache policy libc6-dev
libc6-dev:
Installed: 2.24-11+deb9u4
Candidate: 2.24-11+deb9u4
Version table:
*** 2.24-11+deb9u4 500
500 http://raspbian.raspberrypi.org/raspbian stretch/main armhf 
Packages
100 /var/lib/dpkg/status

Any suggestions? What do I need to install in order to get des_crypt.h?

2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.