I've got a raspberry pi V3. A touchscreen that connects to the DSI port and a Pi NoIR camera module and running the latest lite image. The touchscreen is a non-pi brand screen i found on amazon. It's the "OSOYOO 5 Inch DSI Touch Sceen LCD Display"

When I don't have the screen plugged in, the camera functions as it should. Once i plug in the screen, the camera stops functioning correctly.


raspistill -t 1000

i get this error

mmal: mmal_vc_component_enable: failed to enable component: ENOSPC
mmal: camera component couldn't be enabled
mmal: main: Failed to create camera component
mmal: Failed to run camera app. Please check for firmware updates


$ vcgencmd get_camera

shows that it is detected

supported=1 detected=1

things i've tried

  • 3 amp power supply directly to the gpio pins
  • Updating to latest stable firmware
  • Updating to bleeding edge firmware
  • A second raspberry pi
  • Setting gpu mem to 144
  • adding bcm2708.w1_gpio_pin=18 to my config.txt

    While both are plugged in my screen works 100%. Good picture no artifacts and touch works great. It's just that the camera wont work.

    Any suggestions are appreciated.

1 Answer 1


As it turns out my camera ribbon cable was too long. It worked with the long cable with out the screen, but not with it.

I shortened it to the length I actually needed. Used a small file to reveal the contacts then added a backing so it would seat nicely.

  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year.
    – Ingo
    Commented Jan 23, 2020 at 10:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.