3

I flashed my raspberry pi with ARM server ubuntu but I can’t get my pi to connect to the wifi. I was following this tutorial, which instructs me to use ifconfig, but my pi is telling me that it doesn’t come preinstalled with ifconfig.

Is someone aware of other ways to connect my pi to wifi? I’ve also tried connecting directly through an ethernet cable, but that doesn’t seem to be working either.

3

ifconfig has been removed, in favor of ip: https://unix.stackexchange.com/a/145449/361960

Ubuntu Server is different from Ubuntu Desktop: Ubuntu Server uses Netplan to manage the network connections.

Here's a guide on how to connect to WiFi using Netplan: https://tttapa.github.io/Pages/Raspberry-Pi/Installation+Setup/WiFi-Setup.html

I've never tried running the ARM version of Ubuntu on a Raspberry Pi, you might want to use the specific Ubuntu Server Raspberry Pi version instead: https://ubuntu.com/download/raspberry-pi

| improve this answer | |
  • got a rather cryptic error running sudo netplan apply: [ 2846.098947 ] ieee80211 phy0: brcmf_cfg80211_add_iface: iface validation failed: err=-16, sorting out what that means now – cryptograthor Jan 22 at 18:20
  • Apparently the wifi is connected now though, so maybe I’m good? – cryptograthor Jan 22 at 18:23
  • @7l-l04 that error might be because you're not using the Raspberry Pi version of Ubuntu. – tttapa Jan 22 at 18:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.