1

I have a raspberry pi plugged into a 3440x1440 monitor. Without setting any explicit framebuffer_* options in /boot/config.txt, it comes up at 1184x624. The display is crisp and legible but individual pixels are huge.

I was hoping I could set the framebuffer to a higher resolution, but I'm not meeting with much success. I've tried setting framebuffer_width and framebuffer_height to standard resolutions (like 1920x1080 or 1280x1024), as well as multiples of the current resolution (e.g. 2368x1248).

They all "work" in that the display comes up, but in all cases the text is faded and distorted.

Is there any way to get the raspberry pi console to operate at better than 1184x624?

Edit

This is for a Raspberry Pi 3B, running Raspbian Stretch. Current kernel is 4.9.something.

2
  • Which model of raspberry pi? || What's the OS? || What's your exact problem? "in all cases the text is faded and distorted", it's all about the texts?
    – M. Rostami
    Jan 24 '20 at 16:51
  • I've added the missing information; thanks for pointing that out. The exact problem is as described: "the console text (at resolutions other than the default) is faded and distorted".
    – larsks
    Jan 24 '20 at 17:07
0

It looks like the answer was that I should be setting hdmi_mode and hdmi_group, rather than fiddling about with the framebuffer_* options. Setting...

hdmi_group=2
hdmi_mode=58

...has things working quite nicely.

2
  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year.
    – Ingo
    Jan 26 '20 at 13:59
  • The way Stack Exchange sites work is that you need to wait 24 hours after answering your own question in order to accept it. It hasn't been 24 hours yet.
    – larsks
    Jan 26 '20 at 14:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.