3

My first ever owned Raspberry Pi suddenly died yesterday. I had it working non-stop for like a month until last Friday (I had to hot unplug it). Since I did a lot of troubleshooting in the previous two days, I will try to summarize it here.

First thing first, these are the symptoms: PWR red led is on and stable. ACT led is very very dim (I almost can't see it due to the light coming from the PWR led). All the network-related LEDs are off. No output on HDMI nor in composite video port.

So, my troubleshooting so far (not by order):

  1. Maybe it was some issue with the SD card. Tried with a different one. Reformatted it with 3 or 4 different OSes. Tried the same card in another RPi (same specific version RPi 1 B) and all is working there. No luck.
  2. Checked the voltage between the TP1 and TP2 and it is within the required thresholds. Tried several different PSUs. All the symptoms remain.
  3. Checked the SD card pinout (VCC, VDD, CLK). All outputting values in the accepted range.
  4. Checked the SD_CARD_DET. Is low when the card is inserted and high when the SD card is removed. Nothing unexpected there.
  5. Checked the polyfuse (F3). The voltage difference between the two sides of the expected range (<0.1v). Just to be sure, I left RPi unplugged for 24h hours. No effect.
  6. Checked the components temperature and nothing is overheating at least.
  7. Checked the voltage values in the GPIO header. All is as expected.
  8. Tried to see the output of the serial port (GPIO Rx,Tx) when enabled in the bootcode.bin. Obtained no output.

Maybe I'm forgetting some step, but I did read all the sticky posts on the official RPi forums and did all the recommended checks.

TLDR: RPi 1 B died. All the Google-based and electronics troubleshooting did not help a bit. Maybe someone will come up with a new idea.

  • 2
    It's possible that the processor or the PoP RAM has gone bad, I'd consider them "unserviceable items" for most people. – Ron Beyer Jan 26 at 22:18
  • 1
    @RonBeyer yes, probably it will be something around that. But I would like to be "sure" somehow even if I can't fix it. – JP Dias Jan 26 at 22:21
  • 2
    Yes, I found an old RPi 1 on my desk after I posted that, they must have changed to a different test point system after the 1 came out. – Ron Beyer Jan 26 at 22:29
  • 1
    Yes this version as TP1 and TP2. Probably they changed it, I have a few other RPis (other versions), but never had the need to troubleshooting them. – JP Dias Jan 26 at 22:31
  • Just found this related thread now. However, D17 is cold, so maybe not the same problem. – JP Dias Jan 27 at 11:42
-1

Download a fresh copy of plain Raspbian buster, write it to an 8GB SDCard (or microSD in an adapter).

Boot that in your RPi 1B (which is probably OK unless you've abused the GPIO pins or the power supply has packed up).

When it boots insert your unbootable SDCard in a USB reader, insert the reader in your RPi.

Run for i in 1,2,5,6; do sudo umount /dev/sda$i; sudo fsck -f -y /dev/sds$i; done. Power down, swap the SDCard back and see if the old system boots OK.

| improve this answer | |
  • 1
    Sorry but I think you didn't get the issue right. My problem is not with the SD Card (I took the same SD to another working RPi 1B and all boot up just fine). The problem is that this specific RPi 1B does not boot at any stage whatsoever, nor the ACT led shows any activity of the SD card. So I can't even do what you suggested. – JP Dias Jan 26 at 22:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.