1

I would like to be able to connect to a remote Pi3 in order to view a browser-based config screen for a remote datalogger. The set is as follows

  • Pi3 connected to the mobile phone hotspot network connection.

  • Ubuntu 16.04 with a static IP, used as a slave for the reverse tunnel.

  • Reverse Tunnel created from PI3 back to the Ubuntu server.

The tunnel is up and works well but I need to be able to either remote from the Ubuntu server or through it to reach a browser-based (Chromium) config screen on Pi.
The reason I'm using the Pi3 at the remote site is because of power consumption. I only have a solar panel, trickle charging a battery, which powers Pi, Datalogger, phone(hotspot) and monitoring equipment.

Any thoughts/ideas much appreciated.
Thanks

1

You wrote that the ssh reverse tunnel is up and works well so I do not understand what's the problem. So I will give a short description how I expect it to work.

A ssh reverse tunnel is established for example with:

rpi ~$ ssh -nNT -R <ip_of_ubuntu-server>:8080:localhost:80 username@ubuntu-server

This will make the local port 80 on the RasPi available on the ubuntu-server at port 8080. Port 80 is the default port for the web server. If you browse port 8080 on the ubuntu-server you will see the web server on the RasPi (there it is port 80). So just use the following URL in the browser of the ubuntu-server:

http://localhost:8080

and you will see the home page of the web server on the RasPi. You can browse it the usual way by following links or you can direct select the config page with

http://localhost:8080/config-page.html
| improve this answer | |
  • Thanks for the suggestion, Ingo. Sorry for the delay. I have tried the above and it seems like it should work but it still won't let me connect on the remote machine's browser. Giving the output 'Pseudo-terminal will not be allowed because stdin is not a terminal.' I have tried it both ways, from and to the ubuntu server and it gives the same result. I will see if I can modify your solution to get around the issue. Thanks again – KevLA Jan 31 at 14:19
  • @KevLA "the ssh reverse tunnel is up and works well": what does it mean exactly? How do you verified it? – Ingo Jan 31 at 14:20
  • Ingo, I can view files and directories, even open the browser on the Pi with remote commands from the Ubuntu slave. But I can't view the remote browser on the local (slave) one. – KevLA Feb 3 at 8:47
  • @KevLA I do not understand your problem now. I thought you wanted to show a web page, a browser-based (Chromium) config screen, with the local browser. Isn't it? You can also start the remote browser with X Window. That will run the browser on the remote side and only shows its window local. And you can just use VNC to show the remote desktop and start the browser there. What you want? – Ingo Feb 3 at 10:01
  • Ingo, I couldn't figure out why it wouldn't work in the way you suggested in your last post with VNC so I removed xrdp on the Pi and re-installed and that seemed to have solved the issue. However, I can only connect the tunnel with the original command that I used - 'ssh -R 8080:localhost:80 user@<SERVER_IP>' - just for clarity and other users, the command you suggested in your first post still give the same response and nothing happens until you cancel with Ctrl+c. After bringing up the tunnel I can now use Remmina rdp from the slave and view the Pi's browser. Thanks for your time and help – KevLA Feb 3 at 13:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.