0

I'm using an external drive for my cloud storage. Everything was working fine and then I installed airsonic. I added the tomcat8 user to the www-data group so that airsonic could see the music directory. All worked well and airsonic was scanning the files.

I came back later and the scan had stopped and airsonic was showing an error that the music directory could not be found. Using ls -a in the root of the drive I can't see any files, even as the root user. However, when I plugged the external disk into my desktop and did ls -a as the root user I was able to see that all of the files were still there. Why can't the pi see the files?

I'm using Raspbian Lite Stretch on Pi4. The disk is formatted as Ext4.

Edit: I've solved the problem. The drive wasn't mounted correctly. There was an error with the fstab config so after a reboot, the drive hadn't mounted.

  • Why not Raspbian Buster? The Raspberry Pi 4B is only supported by Raspbian Buster. || raspberrypi.org/forums/viewtopic.php?t=249278 – M. Rostami Jan 29 at 15:19
  • My mistake, I am using buster. – alex87 Jan 29 at 15:20
  • 1
    What is the output of lsblk on the Pi with the external disk connected and the system in the failed state? – Bob Brown Jan 29 at 16:35
  • 1
    Please don't add the solution you have found to the question. Instead make your own answer and accept it after two days. Only accepting an answer will finish the question. Otherwise it will pop up again and again for years. – Ingo Jan 29 at 21:58
1

I found out the drive wasn't mounted correctly because of an error in the fstab config.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.