0

I am trying to install Midori on a Raspberry Pi 3 B+, and I am struggling to access some addresses that Midori recognises as untrusted websites. When I click "trust this website", the browser shows the following error:

Error granting trust: Couldn't find place to store the pinned certificate

pkcs11:library-manufacturer=GNOME%20Keyring ,pkcs1:library-description=PKCS%2311%20Kit%20Trust%Module

When one installs Midori, gnome keyring is installed as part of its dependencies.

I then made the following changes:

$ sudo find / -name gnome-keyring-pkcs11.so 

This yielded:

/usr/lib/arm-linux-gnueabihf/pkcs11/gnome-keyring-pkcs11.so

Then:

sudo modutil -add gnome-keyring -libfile /usr/lib/arm-linux-gnueabihf/pkcs11/gnome-keyring-pkcs11.so -mechanisms RSA:DSA -dbdir ~/.config/midori/

At the end of this, a line indicating that the operation had been successful appeared.

HOWEVER, the same error occurred as quoted above when Midori was used both before and after a reboot.

How can I fix this error?

2
  • No key store is available or it's incorrectly setup. wiki.xfce.org/midori/faq
    – M. Rostami
    Jan 30 '20 at 8:02
  • I followed all of these instructions, and the gnome-keyring was successfully located at the end of it, but I still got the same error above.
    – SolarPilz
    Jan 31 '20 at 9:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.