1

Anyone else using python and pip on Buster lite?

Pip is not working for me on my old dual usb Model B. Just seems to be missing.

I tried installing it using the "get-pip.py" module from the official pip website but this just resulted in a long list of errors..!

In the end I downloaded Buster Desktop and this worked fine even though I only have access via ssh and so don't need the desktop.

So is it me and my old rpi or is there a problem with Buster-lite?

  • have you tried calling pip3 (since your question is tagged Python 3)? – Steve Robillard Jan 31 at 18:03
1

It's neither a problem with Raspberry Pi model B nor a problem with Raspbian Buster Lite. Buster Lite only hasn't pip3 available in its image but it is no problem to get it from its repository with:

rpi ~$ sudo apt update
rpi ~$ sudo apt full-upgrade
rpi ~$ sudo apt install python3-pip
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.