5

UPDATE: As I suspected lately, Ubuntu Server actually boots up. Nothing worked until I tried using an actual HDMI monitor instead of an HDTV or VGA monitor. I suppose the TV will work once I install a desktop environment. Regardless, I still need to get it to work on VGA. I updated the title (is that allowed) and tags accordingly.


First off I know this question must be turning up a lot on forums. I'm aware of the possibility that this might get turned down, but I'll take my chances.

On every attempt to boot my Raspberry Pi with an SD card flashed with Ubuntu 19.10, all I get is this weird looking display as if the monitor is having a stroke:

enter image description here

The Green LED would blink erratically as those white diagonal smudges morph indefinitely, until the LED stops blinking and turns off. At some point some of the streaks are green and red, coincidental with the raspberry pi logo.

I have the Rpi4 4GB RAM version.

I'm using a newly bought 32GB SanDisk Extreme for the Ubuntu. I have another SD card which has Raspbian on it which is working perfectly well with my current display setup--I'm using an old monitor that accepts VGA only. I have a brand-less uHDMI-to-VGA adapter that I've been using with my Raspbian.

I'm strictly following the instructions from Canonical to install Ubuntu.

On each attempt, I format the SD card to FAT32 on Windows using SDCardFormatter, then flash the image from either Raspbian (sudo dd) or Windows (Win32DiskImager), again following Canonical's instructions. I've tried flashing both the 32-bit and 64-bit images. Result is the same for both HDMI ports.

In total I've had 6 attempts, all of which resulted as depicted in the image above.

I've even tried hooking it up to an hdtv, as expected it won't even display anything.

Is there a step I could be missing here that is somehow not mentioned in the instructions?

For one, I did not modify usrcfg.txt param total_mem=3072. But this doesn't seem relevant to the symptom.

It's been really frustrating but I'm willing to try anything else.

EDIT: As suggested by one contributor below, I tried to modify config.txt and put the lines

config_hdmi_boost=4
hdmi_force_hotplug=1

I also put the same lines in usrcfg.txt. I even increased config_hdmi_boost setting to =9. The problem persists, that is, my VGA monitor would still display the distorted figures, and my HDMI HDTV would not detect anything. I'm starting to think that the distorted figures on the VGA monitor are actually manifestations of the Ubuntu boot up screen, albeit corrupted.

  • Please edit into your answer which HDMI to VGA adapter you're using. Some seem to work better than others. – Bob Brown Feb 2 at 19:48
  • Same issue with ubuntu server 18.04.4, raspberry Pi 3 and samsung TV. Same config with raspbian works ok. – loscuropresagio Apr 21 at 13:17
3

With Ubuntu 18/20 there are 2 partitions created on USB (system-boot and writable)

For same issue I searched and tried various combinations but no luck ! It seems I was editing wrong config.txt file. I was editing one from writable/boot/firmware/config.txt. But actually what worked for me is when I edited one from /system-boot/config.txt partition and /system-boot/usercfg.txt. Added following lines in /system-boot/config.txt:

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
hdmi_group=2
hdmi_mode=16

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
config_hdmi_boost=4

Added following line in /system-boot/usercfg.txt:

dtoverlay=vc4-fkms-v3d
| improve this answer | |
  • Worked like a charm!!! Thanks!!! – Yair Daon Sep 15 at 19:48
  • Worked on RPi3 model B + Ubuntu 20.04 Server. – IsaacS Oct 12 at 20:21
1

The same issue happened to me today, so I started finding a solution and found your question.

This post helped me https://www.raspberrypi.org/forums/viewtopic.php?t=34061.

Open your config.txt file from the boot and the below lines.

config_hdmi_boost=4 
hdmi_force_hotplug=1

Try the alternate HDMI port. It worked for me.

| improve this answer | |
  • Problem persists. But thanks for this anyway. I'm starting to think that the Ubuntu actually is booting up, it's just that the display is awfully corrupted. But I don't really know what Ubuntu Server should look like upon first boot / installation. – FartVader Feb 1 at 8:44
0

Add this to you config.txt or on usercfg.txt

hdmi_force_hotplug=1
hdmi_group=2
hdmi_mode=16
hdmi_drive=2

The solution is from youtube video

| improve this answer | |
0

I had the same problem and I solved it in a very simple way: put your SD card into another OS, then open the file "usercfg.txt" and add this line to the end of the file:

dtoverlay=vc4-fkms-v3d

Save and done! Tell me if it worked for you!

| improve this answer | |
  • Where is the file usercfg.txt located? – Ingo Aug 12 at 8:02
  • If you installed a clean ubuntu (without berryboot for example), put the SD card into another OS, open it (whose name is "boot"), and the file is right there – bruno Aug 12 at 23:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.