0

I want to access files from my Raspberry on my Windows machine. I did it previously, but I resetted both my devices some time ago. I haven't made any advanced network configurations to them yet. I installed Samba on the Raspberry with apt install samba. Then appended to /etc/samba/smb.conf:

[shared]
path = /home/pi/shared
valid users = pi
read only = no

(I tried in other instances by adding or removing additional properties to the config, such as browsable, but the same result). Then made a Samba user with smbpasswd -a pi. I tried both using password and no in different instances. I used ufw allow samba, again, one time yes and one time no (before I didn't needed it). While installing Samba I chose both paths of that DHCP config, but the same result. Finally, service smbd restart. U can imagine I did all of those as root user already. The Pi doesn't show on Network folder, but it didn't appear before either. The way I was going was with Add a network location. The folder shared is made on Pi and made it 777 just to make sure it is not the problem, the same as on /home/pi. After trying to add \\192.168.0.100\shared or \\192.168.0.100\pi, the Windows tells me it can't find the location. Below is my network:

192.168.0.1: router
192.168.0.100: Pi
192.168.0.102: Windows

I'm connected to the Pi using ssh, so I'm sure the ip is right. Basically what I did before was bruteforce all known possible configurations, and none showed a good result. I checked the workgroup too and they are the same. I did multiple combinations in restarting the devices (inclusive the router). On Windows I also made combinations of discoverable and file sharing options too

What I did wrong?

  • Welcome. It is possible that your version of Windows will only connect via SMB2 and not SMB1 (not sure which protocol the current Samba uses). Try this guide to allow SMB1. – Ari Feb 1 at 9:46
  • Thx for responding. I allowed SMB1 and opposed to what happened before RASPBERRYPI appears under Network on Windows, but it says it cannot access the network path. The Add a network location doesn't work either. Probably is worth to notice that it worked before even if the device was not listed under Network. What u think @Ari ? – uIM7AI9S Feb 1 at 10:25
  • Not really a question belonging to Raspberry Pi? You may get better/quicker answer at unix.stackexchange.com – Ingo Feb 1 at 11:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.