1

I have a 3B that has worked reliably for a year and now will no longer boot (or if it does, is invisible on Ethernet). I have no HDMI compatible devices, so I cannot verify functionality that way.

The red LED power is steady, and I have verified that the 3V supply is working. I have also verified my power supply provides quality 5V power, and have tried a different power supply known to work. The ethernet lights (yellow and green) are illuminated, and the green flashes from time to time, suggesting it is alive (these lights are dead in the absence of the SD card, so perhaps the device is booting).

When I cycle the power, the green SD LED blinks erratically for a time, but the router does not see the device, even when I switch ports to one I know to be working. I have also tried a different ethernet cable, which is known to work.

There are no USB or other devices connected to the Pi.

After the problem first developed, I reflashed the SD card, which fixed the problem for a few days (running a recent version of Raspberian). I have tried removing and reinserting the SD card.

My next step is to reflash the SD card again, but I suspect that this will only help temporarily.

What should my next steps be?

UPDATE: I got a new 64GB SD card, and that did not fix the problem. Initially, I was able to reboot and run fine, but after a week or so, I rebooted and the pi is invisible to the network. I can see the ethernet blinking, so I know it is seeing traffic, but it appears unable to establish itself on the network.

Is it time for a new pi?

  • Having to re-flash the SD card repeatedly to make the Pi boot is very suspicious. The only thing that I can think of that would repeatedly corrupt the OS is a serious hardware problem (like defective memory) - or you have some kind of virus in your network. – PMF Feb 1 at 12:16
  • 2
    Your problem is probably the mysterious OS "Raspberian" whose users seem to have more problems than most. If you have a Pi3B and are still using the original SD Card - which may be 4 years old, it may just be old age. Spend $10 on a new SD Card - they do wear out. – Milliways Feb 1 at 12:16
  • You really need to see what's going on. If you have a display that will accept DVI input, I've had good success with this: amazon.com/gp/product/B014I8UQJY . Changing HDMI to VGA is somewhat more problematic, but I've had success with these: amazon.com/gp/product/B00SW9JI9A – Bob Brown Feb 8 at 22:45
1

It is possible that your SD Card gets weak over a long time. The problem is that SD Cards doesn't report read/write errors to the operating system. It could be that you can flash it but then it looses some bits and bytes after some days possibly still the same weak cells so the symptoms are always the same. You should consider to use a new SD Card.

| improve this answer | |
  • 1
    I just updated the question; a new SD card did not fix the problem. – watusimoto Feb 8 at 22:35
1

I resolved the problem. It was a misconfigured /etc/fstab file. For whatever reason, the pi refuses to boot when there is an error in this file. I was able to repair the problem by mounting the SD card on a different Linux machine and edit /etc/fstab there. I only managed to figure it out by borrowing a monitor and seeing the messages displayed during the boot process.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.