2

I've got a hard time installing libserial on my Raspi 3B with the recent Raspbian: Both the libserial docs, and the Debian package directory suggest to install the libserial-dev package but a

sudo apt-get install libserial-dev

says that the package in question doesn't exist. So: Is the information from two different "official" websites wrong, or has the package been revoked or…? Compiling the library from scratch doesn't help either as is doesn't even compile due to a bug in some Python source file. Thank you.

UPDATE: This is a list of packages containing libserial in their respective names available to me:

pi@autoradio:~ $ apt list libserial*
Auflistung... Fertig
libserializer-java/oldoldstable 1.1.6-4 all
libserialport-dev/oldoldstable,now 0.1.0-1 armhf  [installiert]
libserialport0/oldoldstable,now 0.1.0-1 armhf  [Installiert,automatisch]

There is a version of libserial for Stretch, but apparently not available (any more?). 0.6.0 seems to be not accepted due to an outdated libc6 and libstdc++:

pi@autoradio:/import/valen/autoradio $ sudo dpkg -i libserial0_0.6.0_rc2+svn122-4+b11_armhf.deb
(Reading database ... 142438 files and directories currently installed.)
Preparing to unpack libserial0_0.6.0_rc2+svn122-4+b11_armhf.deb ...
Unpacking libserial0:armhf (0.6.0~rc2+svn122-4+b11) over (0.6.0~rc2+svn122-4+b11) ...
dpkg: dependency problems prevent configuration of libserial0:armhf:
 libserial0:armhf depends on libc6 (>= 2.28); however:
  Version of libc6:armhf on system is 2.19-18+deb8u10.
 libserial0:armhf depends on libstdc++6 (>= 5.2); however:
  Version of libstdc++6:armhf on system is 4.9.2-10+deb8u2.

dpkg: error processing package libserial0:armhf (--install):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.19-18+deb8u10) ...
Errors were encountered while processing:
 libserial0:armhf

UPDATE #2: Maybe I've really got an age-old version of Raspbian:

pi@autoradio:/import/valen/autoradio $ lsb_release -a
No LSB modules are available.
Distributor ID: Raspbian
Description:    Raspbian GNU/Linux 8.0 (jessie)
Release:        8.0
Codename:       jessie
2

You may not run the latest version of Raspbian which is "Buster". I just tested and installed it without any problem.

However, try to install it manually if it doesn't work anyway:

wget http://ftp.us.debian.org/debian/pool/main/libs/libserial/libserial-dev_0.6.0~rc2+svn122-4+b11_armhf.deb  

Then:

dpkg -i libserial-dev_0.6.0~rc2+svn122-4+b11_armhf.deb

Source Debian list.

| improve this answer | |
  • No use: libserial-dev depends on libserial0, which itself needs a fairly new (2.28) libc6 and libstdc++ (5.2). – Neppomuk Feb 3 at 20:46
  • @Neppomuk Did you try to install libserial0, libc6 and libstdc++? – M. Rostami Feb 4 at 9:34
  • No use! Too many unfulfilled deps. I'm gonna upgrade my Raspbian installation to Buster now. Seeya soon! – Neppomuk Feb 4 at 20:02
2

It's really time to use Raspbian Buster now. Jessie is deprecated and since beginning of this year it has finished support from Debian. On my Raspbian Buster repository I find:

rpi ~$ apt list libserial*
libserial-dev/stable 0.6.0~rc2+svn122-4 armhf
libserial-doc/stable 0.6.0~rc2+svn122-4 all
libserial0/stable 0.6.0~rc2+svn122-4 armhf
libserializer-java/stable 1.1.6-5 all
libserialport-dev/stable 0.1.1-3 armhf
libserialport0/stable 0.1.1-3 armhf

All things are available including libserial-dev. Maybe you have to use Buster?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.