1

I have issue with curl and wget transfer speed on my new Raspberry Pi 4 1GB. Pi is sonnected to the router by ethernet cable. When I try to download for example a large test file or something from github transfer speed is around 30-40KB/s. It does not matter if the output is a file on sd card or /dev/null. When I run speedtest it shows 500Mbps and that is what my ISP offers.

When I try run the same curl/wget commands on my other RPi2b speed is maxed out for its 100Mbps ethernet.

| improve this question | | | | |
  • Ah, Rpi4B 1GB download 30-40kB/s is ridiculously slow. I have a Rpi4B 1GB/2GB to test right now. Can you give me the exact wget command for a very large file "wget http: ..." and any check speed commands your are using for me to test for you to compare? – tlfong01 Feb 5 at 9:01
  • I am using this site for a mentioned large files thinkbroadband.com/download and speedtest is this one speedtest.net/apps/cli – krzysiej Feb 5 at 9:19
  • Many thanks. I hope to try it in 60 minutes, and let you know the results. Cheers. – tlfong01 Feb 5 at 9:38
  • I first tried using my Win10 to download 1GB from thinkBoardBand and 2.5GB rpi full image from Rpi download site. The 1GB predicted 45 minutes, and 2.5GB predicted 3 hours. This is strange, it usually should take much less than that. I have not tried Rpi4B yet, but I don't expect any good news. Is it because the brexit reason? – tlfong01 Feb 5 at 10:09
  • Anyway, I am now downloading using Rpi4B the same 1GB file, the estimated time varies from some 5min to 13min left. Ned to wait. Will report progress later. – tlfong01 Feb 5 at 10:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.