5

I recently installed buster on a Pi 3 Model B. Trying to setup a von (using pivpn) I realised that iptables is not working.

I've learned that there's legacy mode and nft. Here's part of the output from hostctl and what I get when I run either version. I've tried updating and upgrading with apt.

  Operating System: Raspbian GNU/Linux 10 (buster)
            Kernel: Linux 4.19.93-v7+
# iptables-nft
iptables/1.8.2 Failed to initialize nft: Protocol not supported
# iptables-legacy -L
iptables v1.8.2 (legacy): can't initialize iptables table `filter': Table does not exist (do you need to insmod?)
# iptables-legacy -m comment
iptables v1.8.2 (legacy): Couldn't load match `comment':No such file or directory

I find it hard to believe that I am the only one experiencing this, but I really don't see anything helpful on the web (there are a couple of posts but no solutions). I was going to try to downgrade iptables, but from what I see there isn't an older version packaged for buster to do that.

7

One of those days ... although the pi was recently booted, it seems that it needed a reboot - probably after some update?

When I was troubleshooting, I had

ls /lib/modules/$(uname -r)
ls: cannot access '/lib/modules/4.19.93-v7+': No such file or directory

After more research, I figured maybe a reboot was required, after that I had

# uname -r
4.19.97-v7+
# iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination
  • 1
    Argh. I've been caught by this multiple times (in different ways). Some idiot at Raspbian believes it is fine to update the kernel then (without checking which version is still running!), delete the modules from the old one. >_< – goldilocks Feb 9 '20 at 15:04
  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year. – Ingo Feb 12 '20 at 19:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.