I have a new Raspberry Pi 4 connected to a motherboard that supplies very stable voltage and current to the Pi. I flashed an SD card with the latest distro and realized that sometimes when I run reboot or shutdown -r now from the command line, the Pi does not boot. The green LED blinks 7 times showing that the board is unable to find "kernel.img" (according to this resource). The Pi always boots successfully from a powered-off state, but not when rebooting from software.

My setup:

  • Raspberry Pi 4B, 2GB RAM.
  • Raspberry 7" Touchscreen.
  • Raspbian distro: 2020-02-05-raspbian-buster.
  • SD card: Samsung EVO Plus 32GB

I have already read this topic that deals with Pi 4 boot issues. The Pi 4 related post says this:

Shortly after launch there appeared to be an issue with some 32GB cards that expressed itself with that the boot aborts. The four raspberries appear followed by a short burst of text, then the system halts. The base of the issue seems to be the card reader of the PC used, but later firmware seems to have solved the issue: https://www.raspberrypi.org/forums/view ... 8&t=248968 in the meantime, if you have this exact problem, I would suggest using a 16GB card, try using another card reader, or upgrade the boot code.

However, the post is dated Jun 25, 2019, and there've been already 2 releases of Raspbian Buster since then, so I guess it's not related to the SD card problem. Furthermore, I have already flashed the SD card using a new reader/programmer and, as I said before, boot always succeeds when booting from a powered-off state.

EDIT (2020-02-12):

I posted a message on the Raspberry Pi forum and apparently there is a kernel issue that, as of Feb 05 kernel update, it makes the Pi4 not reboot after issuing the command. Further info here.

  • 4
    I would suggest you post this on the official Raspberry Pi forums raspberrypi.org/forums
    – CoderMike
    Feb 11, 2020 at 9:01
  • 1
    @CoderMike thx, I will
    – Claudi
    Feb 11, 2020 at 10:13

2 Answers 2


The first step (which in retrospect didn't help) is to configure your bootloader with POWER_OFF_ON_HALT=0 and WAKE_ON_GPIO=1 (I think the latter forces the former). Your RPi will never be fully shut down in this way, but it won't power down during a reboot either.

The next thing you could try is updating the bootloader with sudo rpi-eeprom-update, and testing a different board if available.

Green LED blinking on power down is not related to the boot process.

  • Thanks for the reply. However, reading the documentation you linked I don't see how can it help to my solve problem. Actually, by setting WAKE_ON_GPIO=1, "will run in a lower power mode until either GPIO3 or GLOBAL_EN are shorted to ground". I'm not looking for that. Also, I'm neither looking for halting the Pi but for rebooting from the command line.
    – Claudi
    Feb 11, 2020 at 9:42
  • It will help because rebooting using GPIO and rebooting from command line both require 3.3V to be present after the system shutdown, and I guess that's what you're missing. You can measure the voltage on the 3.3V pin when your system halts during a reboot to confirm that. Feb 11, 2020 at 9:52
  • Thx, I will try then.
    – Claudi
    Feb 11, 2020 at 10:14
  • 1
    Bad news. My bootloader settings are already set the way you told me...
    – Claudi
    Feb 11, 2020 at 10:27
  • 1
    Well, I managed to reboot the Pi and leave it in that frozen state. The 3V3 voltage is still in there.
    – Claudi
    Feb 11, 2020 at 11:31

OMG I just figured out the problem. I experimented with unpluggint he screen which worked, but who wants that?!?!!

Then I started unplugging my ethernet, keyboard and wireless mouse. Tada!! it restarts that way too!

  • 1
    This is probably a power supply issue...
    – goldilocks
    Mar 19, 2021 at 21:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.