0

Previously the omxplayer is working fine, until I resized the boot partition (because I run out of sdcard and windows cannot read ext partition), and the omxplayer no longer plays anything. The system boots fine tho...

I have already tried recompiling the omxplayer from https://github.com/popcornmix/omxplayer, but it still same problem

For some files, it returned "have a nice day ;)". But when I tried test video (located at /opt/vc/src/hello_pi/hello_video/test.h264), it returned "Aborted"

Is there anything can I do except resize boot partition back or start with fresh image?

  • As here, omxplayer is so buggy and terrible for playing movies. sometimes keyboard controls don't work, for no reason. Space bar just will not pause, escape will not kill omx etc. So there if you wanna get a result without wasting time, "start with fresh image." – M. Rostami Feb 12 '20 at 8:25
0

Eventually, I found that one of library file (libboost_filesystem.so.1.62.0) is corrupted when I resized the partition. But then, the system is still Raspbian Stretch, so I decided to upgraded it anyway to Buster. And, it works again. (Also don't forget GPU memory, 64M is not enough for me)

Well if you can't upgrade because it's already latest version, and you have some "bash" skills, well you can experiment this little command. What it does is find any .so files that didn't identified as ELF, and then try to reinstall it via apt.

find /usr/lib -type f -exec file {} \; | grep \\.so | grep -v ELF

There's other location such as /opt/vc/lib you might want to check.


But the easiest solution would be start fresh, but unfortunately it's not for me, I might wasting more time setting up everything than troubleshooting what's wrong. Your experience may vary :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.