2

For making remote ssh connection on raspberry pi 3B (os raspbian), it need to close wifi connection (to use only wired connection instead), I have found the command on SE is

sudo iwconfig wlan0 txpower off

But the problem is now I cant switch on back the wifi. I have used the code

sudo iwconfig wlan0 txpower on

it shows error,

Error for wireless request "Set Tx Power" (8B27) :
    GET failed on device wlan0 ; Input/output error.

Now what is the way to get the wifi again?

2
  • Is this relevant? – Peter K. Feb 13 '20 at 16:02
  • You are asking the wrong question. There are much better solutions to your problem than fiddling with low level powering the interface. It may also produce other error messages by the operating system expecting a powered interface. – Ingo Feb 16 '20 at 12:16
1

For making remote ssh connection on raspberry pi 3B (os raspbian), it need to close wifi connection. (to use only wired connection instead)

You can do it by ifplugd package with filling the /etc/network/interfaces out. Follow this link to do that. You can be enabled to disable wireless networks automatically when a wired cabled plugged.


But the problem is now I cant switch on back the wifi.

However, if you are concerned about this method, you should try sudo rfkill unblock wifi before that command. Also, check this link out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.