1

We are trying to install jevois-inventor onto the ubuntu18.04 but we flashed the ubuntu18.04 onto a raspberry pi 4 which is an arm64 architecture(we think). We tried to install amd64 packages individually on ubuntu terminal, but we can not install build-essential, gcc, etc packages for amd64. We are new to ubuntu and raspberry pi so any information would be very helpful.

  • 1
    The Pi is ARM NOT amd – Milliways Feb 14 at 7:33
  • While I haven't tried it myself, you should be able to run arm64 code on the Pi4 (when using the correct kernel), but not amd64. That's something very different. – PMF Feb 14 at 20:10
2

There would be no way to install amd64 packages directly on the PI4.

You might need to find a arm version of the packet or recompile it with the correct flags. I don't think I understood, but if you want to compile code for the amd64 architecture, it would be possible in the Pi. What you can't is run packages already compiled for amd64 on the PI.

If you absolutely need to run the amd64 packages on the PI Linux installation, the easiest solution is to install a minimal base machine on the board and install a hypervisor, as VirtualBox, Xen project or VMWare.

This will allow the creation of a abstraction layer from the arm to the amd64 architectures.

This will also create a huge overhead on the board, because it will need to sustain two kernels running at the same time, sharing process and memory.

  • Said Hypervisors don't emulate an x86/x64 architecture. The hardware of the virtual machine is therefore (almost) the same as the one of the host, especially do they get the same CPU type. So they can't be used to run amd64/x64 on arm. – PMF Feb 14 at 20:09
1

What is this Multiarch?

Debian said: Multiarch lets you install library packages from multiple architectures on the same machine. This is useful in various ways, but the most common is installing both 64 and 32-bit software on the same machine and having dependencies correctly resolved automatically. In general, you can have libraries of more than one architecture installed together and applications from one architecture or another installed as alternatives. Note that it does not enable multiple architecture versions of applications to be installed simultaneously.

Multiarch - HOWTO
Multiarch - Implementation


In addition, I didn't test but you can install amd64 packages on a raspberry pi with armhf or arm64 architecture.

Using Multiarch to cross-build for Raspbian

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.