0

New to Raspberry and just experimenting for now. I bought a Kuman 7" touchscreen and got the display to work, but I am having trouble installing the matchbox touchscreen software.
I moved the software from the CD-ROM that came with the display to a USB memory stick and started following the command-line instructions.
I am getting errors like:

pi@raspberrypi:~ $ sudo apt-get install libfakekey-devlibpng-devautoconflibxft-devlibtoolautomake –y
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libfakekey-devlibpng-devautoconflibxft-devlibtoolautomake
E: Unable to locate package –y

Do I need to manually move the install files to a specific directory on the Raspbian SD card?

Is there a tutorial on how to install and configure alternative hardware somewhere on the Raspberry web site?
I am guessing what is going on based on my Windows experience...

Also, there is a software image file on the CD-ROM, can that be unzipped to the Raspbian computer and should it install itself? (my guess is: not).

Thanks!

0

There appears to be a couple of problems with your installation instructions. First off, the -y should go before "install". This is a flag to say "automatically answer yes to any prompts", by putting it at the end, it's being treated as a package name to install and failing when it can't find it.

More importantly, there should be spaces between the package names - for example,

sudo apt-get -y install libfakekey-dev libpng-dev autoconf libxft-dev libtool automake

Currently it's looking for a lengthy name that doesn't actually exist as an installable package, hence the error.

If you get any further errors, it would probably help if you're able to point us to a copy of the installation instructions.

Some googling led me to https://www.amazon.com/Kuman-Capacitive-Display-Raspberry-SC7B/dp/B01F3801A2 And then to https://mega.nz/#F!iI9WjThL!VHRNzC44Cxlx7CjIQQJqBQ

Assuming it's the files at that mega.nz site, I see a few more errors, most notably spaces missing after the sudo command further down (sudonano and sudochmod should, of course, be "sudo nano" and "sudo chmod")

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.