2

I'm at wits' end, trying to figure out why my HelloWorld console app doesn't work. my Raspberry is a B3 running Raspbian Buster Lite.

dotnet --info shows the following: sceenshot of raspberry pi showing dotnet --info

I followed the instructions to publish an app, by using the publish add-in of Visual Studio, with

    target framework = netcoreapp3.1
    target runtime = linux-arm
    deployment mode = Self-contained

after using SCP to upload the publish folder, I chmod 755 the HelloWorld.dll, and then do:

    dotnet HelloWorld.dll

but I always get:

An assembly specified in the application dependencies manifest (deps.json) was not found: runtimepack.Microsoft.NETCore.App.Runtime.linux-arm; Version 3.1.1

I tried various suggestions about how to publish, but they all create the same result.

1
  • 1
    Did you find a solution? I am dealing with this issue myself with version 3.1.8 Sep 26, 2020 at 21:38

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.