2

I have connected my raspberry pi model 3 B to my laptop remotely using SSH. I am able to connect to the terminal, but when im trying to view using VNC viewer all I am getting is a gray screen.

3
  • 2
    I don't believe this is a problem specific to the Raspberry Pi, and you may find more information by googling "vnc viewer gray screen"
    – user96931
    Commented Feb 19, 2020 at 16:02
  • Hello. Can you add to your question the OS you've installed to your SD card and which desktop manager you're using? Commented Feb 23, 2020 at 20:18
  • Hey, the OS i have installed is buster lite. After enabling the GUI settings it worked fine.
    – apurva_b
    Commented Feb 24, 2020 at 12:00

1 Answer 1

1

If a grey screen is encountered change /root/.vnc/xstartup contents to this: Source

#!/bin/sh
unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS
startxfce4 &

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.