Like the title, I updated the Raspbian from Jessie to Buster, and when I restarted my Pi 2 Model B, wlan0 suddenly not associated, I noticed that could be my Wifi dongle problem. But when I get to raspi-config in Terminal to change Wifi settings, it just threw me this error box "Could not communicate with wpa_supplicant"

P/S: Ethernet is still working properly,

Is this a system bug or just an error ? If that an error, how should I fix it ?

My Wifi dongle is TP-Link TP-WN725N Wireless N

Thank you ![enter image description here]1


1 Answer 1


Raspbian is a flavor of Debian. Debian has a powerful package management system which can full upgrade from an old version to the next one, e.g. from version Jessie to version Stretch but it cannot upgrade across two or more versions, e.g. from Jessie to Buster (the successor of Stretch). To do such things you have first to upgrade to Stretch and then upgrade again to Buster. With each upgrade there are some settings left from the old version so an upgrade is not 100 % the same as a new installation. It is a good idea to make a new installation after an upgrade.

Anyway, this is said for Debian. For Raspbian there is no official support for upgrades by the Raspberry Pi Foundation. They say you should always start a new version from an image. For experienced user who can handle the upcoming problems it may be possible to do an upgrade. But I'm afraid you will not find much help about your problems because what you have done isn't defined and reproducible.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.