2

I've recently acquired a Raspberry Pi 4/4GB, which I'm planning to use in place of a failed motherboard/GPU in an old 24" iMac, re-using only the display, PSU, fans and speakers.

Initially, I'm at the point of trying to get the board to boot to a usable state with Raspbian Desktop, connected to the official Raspberry Pi USB C PSU, an external HDMI display and a USB keyboard and mouse.

After downloading and installing the February 2020 (release date 2020-02-13) "Raspbian Buster with desktop and recommended software" to a 32GB SanDisk SD card, I can get the board to boot, but appears to be totally frozen after getting to display the graphical desktop - the mouse cursor does not move, neither does it respond to keyboard input.

I'm aware there at least have been issues with the 4GB variant of this board with some versions of Linux, in terms of not enabling USB, but I've not managed to ascertain whether this should now be fixed. The Raspbian Release notes suggest the distro does support the Raspberry Pi 4, but makes no mention of specific fixes, other than a change to ensure the SPI EEPROM is updated to the latest version.

What I've tried so far:

  • Editing /boot/config.txt from my Mac and making the following changes, before transferring to the card to the Raspberry Pi:
    • Adding max_usb_current=1
    • Adding total_mem=3072
  • Trying 3 different USB keyboards and mouse, including one known to work with other Raspberry Pi boards.
  • One optical mouse I've tried which uses visible red light flashes briefly when plugged in (drawing too much power?).
  • Trying the keyboard and mouse in both the USB and USB 3 ports.

Unfortunately the board will only boot once like this - I have to reflash the whole SD card before it will boot again, probably because I'm not able to properly shut down the system before powering off.

My questions are therefore:

  • how can I avoid having to reflash the SD each time? This is really slowing down troubleshooting!
  • is there any way to test whether the system is running or has frozen without working USB?
  • would changes written to /boot/config.txt on a Mac prior to boot take effect? If not, what would be the correct approach, given I cannot currently interact with the system?
  • is there another way to interact with the booted system other than USB? For example, does the default install enable sshd?
  • is my Raspberry Pi 4 potentially faulty? The RP4 has been out a while now, and it seems reasonable to expect it to work out-of-the-box with Raspbian.
  • 1
    Comments are not for extended discussion; this conversation has been moved to chat. – goldilocks Feb 22 at 18:08
  • 1
    This issue was eventually tracked down to a faulty Raspberry Pi. Fortunately I was able to get it exchanged and the new board works perfectly without any workarounds required. – Andrew Ebling Mar 7 at 15:47
2

would changes written to /boot/config.txt on a Mac prior to boot take effect?

Yes.

You can see (and edit) all the files on the boot partition - exactly the same as any USB key.
This will usually be mounted on the Mac at /Volumes/NO NAME although the name may differ.

Don't add max_usb_current=1 it only does anything on a Pi2.

There is no need to add total_mem=3072 this is only needed on some Ubuntu installations (because they do not use Foundation firmware).

For example, does the default install enable sshd?

No.

SSH can be enabled by placing a file named 'ssh', without any extension, onto the boot partition of the SD card.

You may also want to enable WiFi access.

Both of these are detailed in How to set up networking/WiFi

is there any way to test whether the system is running or has frozen without working USB?

I add dtparam=act_led_trigger=heartbeat to config.txt
This produces a distinctive heatbeat pattern on the ACT LED which is disrupted if the OS is frozen (or very busy).

I'm not able to properly shut down the system before powering off.

There is no need to pull the power to shutdown a Pi. If you can't run the shutdown command you can use the GPIO. I use dtoverlay=gpio-shutdown,gpio_pin=21 to shutdown my headless Pi - either with a button or inserting a shunt on pins 39,40. See https://raspberrypi.stackexchange.com/a/77918/8697

| improve this answer | |
  • Awesome - thanks so much for taking the time to provide all this useful info! Will try and make time to try these suggestions out over the next few days. – Andrew Ebling Feb 23 at 9:32
  • if it's not the total_mem=3072 issue, do you have any other ideas what might be causing the board to freeze or not activate USB? If I use the "lite" version of Raspbian, I can't even log in on the terminal. – Andrew Ebling Feb 23 at 10:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.