1

I am running AGL (more about it here) image on Raspberry PI 3. I want to send application files from my laptop (where i build it and which has stable wi-fi connection) to the raspberry using scp. What I try to do is to connect raspberry with the laptop using ethernet cable. My laptop shows that wired connection (bot no dhcp automatic IP is assigned) is set however raspberry board only has yellow light but no green.
I am using screen to access raspberry with serial console and when I boot an image it says no ethernet found.
ifconfig has following output in raspberry:

raspberrypi3:~# ifconfig
eth0      Link encap:Ethernet  HWaddr B8:27:EB:00:BD:64  
          inet addr:169.254.213.107  Bcast:169.254.255.255  Mask:255.255.0.0
          inet6 addr: fe80::ba27:ebff:fe00:bd64/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:15 errors:0 dropped:0 overruns:0 frame:0
          TX packets:179 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2958 (2.8 KiB)  TX bytes:57722 (56.3 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1080 (1.0 KiB)  TX bytes:1080 (1.0 KiB)

Here is info about wired connection from the laptop on the screenshot below
enter image description here]

How do I get my raspberry board to detect ethernet connection?

EDIT 1
After changing static IP of laptop to match PI's static address pingng PI from laptop returns destination host unreachable. For now on laptop:

enp8s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 168.254.141.10  netmask 255.255.0.0  broadcast 168.254.255.255
        inet6 fe80::c18:cd6b:db:db62  prefixlen 64  scopeid 0x20<link>
        ether e8:6a:64:0e:48:27  txqueuelen 1000  (Ethernet)
        RX packets 105  bytes 44568 (44.5 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 71  bytes 7194 (7.1 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

On PI:

eth0      Link encap:Ethernet  HWaddr B8:27:EB:00:BD:64  
          inet addr:169.254.141.12  Bcast:169.254.255.255  Mask:255.255.0.0
          inet6 addr: fe80::ba27:ebff:fe00:bd64/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:124 errors:0 dropped:0 overruns:0 frame:0
          TX packets:201 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:14406 (14.0 KiB)  TX bytes:67931 (66.3 KiB)
  • 2
    169.254.0.0/16 is a link local address and your eth0 interface is already up. I don't know much about AGL, but it might be expecting an IP from a private IP range. It might also be trying to detect connectivity by connecting to a remote host. What happens when you set static IPs from a private network range? (make sure both are on the same subnet) – Tenders McChiken Feb 24 at 13:48
  • 2
    You have 168 as the first octet of the laptop address and (correctly) 169 as the first octet on the Pi address. Really, just click "Link-Local only" on the laptop and let the OS assign a link-local address. – Bob Brown Feb 24 at 15:57
5

The Pi and the laptop are on different networks. I suggest setting a static address in the 192.168.8.0/24 subnet on the Pi. You'll need to use one that hasn't been assigned by the DHCP server on your network.

Alternatively, since it seems that the laptop's address was set manually, you could set an address in the link-local network (169.254.0.0/16) on the laptop. Possibly all you need to do is click that "link-local only" button.

The first two or three numbers in the IPv4 address must be the same for two computers to communicate without routing. Wikipedia has an explanation of subnets.

  • Thank you for your answer. I will try to set static IP first for PI and if it won't have effect I will try with the laptop and let you know my results – ktv6 Feb 24 at 14:50
  • Happy to help. If you find that my answer corrected your problem, please "accept" it by clicking the check-mark. That keeps it from popping back up looking for more answers. Um, it also adds to my reputation score. – Bob Brown Feb 24 at 14:54
  • Also, you might try "Link-Local only" on the laptop first as it is easier to do and easier to undo. – Bob Brown Feb 24 at 14:56
  • edited question with new information – ktv6 Feb 24 at 15:42
  • Setting laptop's IP to link-local worked for me. I now can ping PI from laptop and vise versa, scp works too. Thanks a lot for your time and help!!! – ktv6 Feb 24 at 16:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.