1

I tried many answers on different websites. Raspberrypi.org, this site, linux.com, and others I cannot list. I tried Analogue with sudo raspi-config. I also tried amixer cset numid=3 1. I tried updating and upgrading. But nothing is working. I tried the hello.bin wave sound, that worked. But nothing else is working. I verified the speakers work on a Windows PC and macOS X Mojave. But they don't work on Raspbian. Do I need to re-install the OS? If so how can I back up the configs without losing everything again?

Your help is appreciated. I'm not very experienced with my Pi, so please be patient with me, as I am autistic.

EDIT: The hello thing does work. But no other videos or .wav files are working. I would set the volume to max, and then right-click the icon and click 'Analogue'. But then the sound resets to mute every time.

EDIT 2: VLC Media Player

EDIT 3: I just edited the file and saved it. I rebooted and tried the audio, but it still resets to mute every time I turn the volume>0

4
  • nano /usr/share/alsa/alsa.conf and change defaults.ctl.card 0 and defaults.pcm.card 0 to defaults.ctl.card 1, defaults.pcm.card 1 then save alsa.conf file. Finally reboot. Note that you need a reboot after any configuration. – M. Rostami Feb 24 '20 at 17:50
  • I just edited the file and saved it. I rebooted and tried the audio, but it still resets to mute every time I turn the volume>0 – Arbiter Feb 25 '20 at 0:11
  • So, the problem is not that the audio is disabled, it's about resetting config? Right? – M. Rostami Feb 25 '20 at 5:29
  • I don't know, I'm not an expert on things. I'm not sure which configs to change. I already did your response, but didn't work. I really don't want to re-install Raspbian. – Arbiter Feb 25 '20 at 17:10
0

Okay, I found the answer myself. I feel very dumb of not trying this out, but here is the A:

Without selecting an output device, I just turned the volume to 100% and hit play on VLC. Ta-da.........

I can't believe I didn't think of trying this out.

1
  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year. – Ingo Mar 2 '20 at 5:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.