0

I have a white and a black raspberry I am trying to connect to my server using a Ethernet to USB dongle (the usb part goes in the server).

[xxx@localhost]$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 059: ID 0bda:8152 Realtek Semiconductor Corp. RTL8152 Fast Ethernet Adapter
Bus 001 Device 060: ID 0bda:8152 Realtek Semiconductor Corp. RTL8152 Fast Ethernet Adapter

When I check in with ifconfig on the server if they are connected, I can see that they both get a separate network interface: enp0s20f0u6 and enp0s20f0u7 but only the latter has a connection.

enp0s20f0u6: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether 00:e0:4f:xx:xx:xx  txqueuelen 1000  (Ethernet)
        RX packets 691  bytes 48566 (47.4 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp0s20f0u7: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 169.254.xxx.xx  netmask 255.255.0.0  broadcast 169.254.255.255
        inet6 fe80::2e0:xxx:xxx:xxx  prefixlen 64  scopeid 0x20<link>
        ether 00:e0:4a:xx:xx:xx txqueuelen 1000  (Ethernet)
        RX packets 819  bytes 57564 (56.2 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 77  bytes 7484 (7.3 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

I am only able to access one of the raspberry's (ping & ssh using its 169.254 ip) and its the first one I connect to the server.

This is what I get when I use arp on the server:

? (IP_BLACK) at <incomplete> on enp0s20f0u7
? (IP_WHITE) at MAC_WHITE [ether] on enp0s20f0u7

I don't understand why they both are on the same network interface, and why I am only able to see one of the MAC adresses.

I tried to manually add the black raspberry to its own interface

? (IP_BLACK) at MAC_BLACK [ether] PERM on enp0s20f0u6

but still I cannot ping it. I have the same issue if I first connect the black one, who then works, and then the white one, but then only the black works.

Does anyone know what is happening and what I'm doing wrong?

UPDATE with info comment:
The server is actually a simple desktop connected to a closed network with an ethernet cable. This closed network does not provide wifi, so my solution to access the two raspberry's was to connect them with an ethernet to usb cable directly to the server.

2
  • I think you'll need to use static IP addresses. RFC 3927 auto-assigned addresses all fall in the same range (169.254/16). This route can only be assigned automatically to one device at the same time.
    – Fred
    Mar 5, 2020 at 12:05
  • The problem does not belong to Raspberry Pi. It is about the Desktop computer. You should better ask at superuser.com
    – Ingo
    Mar 5, 2020 at 19:20

1 Answer 1

1

what kind if "server" is this?

my best guess is that the two USB ethernet adapters connected to the server are giving ip addresses on the server, not giving IP addresses to the pis. since there are 169.254 addresses, you don't have a dhcp server, so your server is giving itself an apipa address. and there are probably good reasons for a machine to not give itself two apipa addresses, so only your first ethernet adapter is getting an address.

i would assume that the correct set up for this is a server connected to an ethernet switch with an ethernet cable, and two raspberry pis connected to the same ethernet switch with ethernet cables. then they'd all get apipa addresses and could talk to each other.

but i don't know exactly what you're trying to accomplish.

1
  • Hi, the server is actually a simple desktop connected to a closed network with an ethernet cable. This closed network does not provide wifi, so my solution to access the two raspberry's was to connect them with an ethernet to usb cable directly to the server. Thank you for you advice regarding setting up an ethernet switch, I will look into that. Mar 5, 2020 at 9:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.