0

So my project need to use Team-viewer or Any-desk to remote control the PI 4 after boot.

the Problem i'm facing if the PI Plugged to Screen everything works perfectly and the 2 programs run automatically, But the Project should not have screen Plugged to it then it will face a problem to not open these programs on Boot up.

I already set the programs to start at boot but not sure why not working if the screen not plugged.

is there is a way to make the PI that there is plugged in Screen after booting ?

edit: I did able this option hdmi_force_hotplug=1 also I add

DVI DMT (35) RGB full 5:4, 1280x1024 @ 60.00Hz

hdmi_group=2 hdmi_mode=35

and I set the resolutions here raspi-config, as I open the Pi using remote desktop from the same network I still can open and the thing that still not starting by boot is TeamViewer and anydesk , the moment I plug the screen and reboot everything will work and if I take it and reboot nothing working (teamviewer and anydesk

2

There is an option hdmi_force_hotplug=1 in config.txt, although AFAIK the Pi4 will always use HDMI unless overridden, but it will do no harm.

You should also set a resolutions in raspi-config otherwise the Pi will use an impossibly small screen.

On my Pi4 this sets

#DVI DMT (35) RGB full 5:4, 1280x1024 @ 60.00Hz
hdmi_group=2
hdmi_mode=35

and this can be set manually in config.txt

The Pi4 has an additional GUI Screen Configuration utility which allows the screen to be configured after boot.

| improve this answer | |
  • I already test it out but still facing the same problem like nothing change – Ghaz Almoosa Mar 7 at 1:13
  • @GhazAlmoosa If you want help you have to provide some concrete data - (which you should edit into your Question). "nothing change" is not useful - what EXACTLY did you do? What does tvservice -s show? – Milliways Mar 7 at 1:22
  • sorry, I did able this option hdmi_force_hotplug=1 also I add #DVI DMT (35) RGB full 5:4, 1280x1024 @ 60.00Hz hdmi_group=2 hdmi_mode=35 and I set the resolutions here raspi-config as open using remote desktop from the same network I still can open and the thing that still not starting by boot is TeamViewer and anydesk , the moment I plug the screen and reboot everything will work and if I take it and reboot nothing working (teamviewer and anydesk) – Ghaz Almoosa Mar 7 at 7:56
  • I'm really sorry, as I'm new on all of this and I'm windows user I cant get it what other info I should get for you, but I can give you access to my Pi to have a Look if that possible I will be grateful ,this my email ghazpi4@gmail.com .Thank you so much – Ghaz Almoosa Mar 7 at 9:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.