0

I am trying to SSH into a RPI 3B+ using a mac. I have etched the Raspbian Buster(Feb 2020)full image onto a micro SD card and also have added the "ssh" and "wpa_supplicant.conf" files into the "boot" partition which was created. But after putting the the card into the RPi lot and turning the power on, the RPi is not connecting to my network (Mobile Hotspot). I've checked using Lanscan and have also checked the "Connected Devices" section of my phone. I can't seem to find out what the problem is.

Can someone please help me out? Thanks.

-1

Why don't you just use real vnc?https://www.realvnc.com/en/connect/download/viewer/raspberrypi/

I've used this and it works great. Also, this seems to be a duplicate to this: SSH to RPI using android hotspot and PC

Look at here, and see if it gives you any hints. Is you mac also connected to the hotspot?

| improve this answer | |
  • Don't ask questions in an answer. – Ingo Mar 10 at 11:16
-1

It is working now. I have added the following lines to my wpa_supplicant.conf file:

country=US
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

change the country code to your own country.

| improve this answer | |
  • What does work with these lines? What is the complete content of /etc/wpa_supplicant/wpa_supplicant.conf? – Ingo Mar 10 at 11:19
  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year. – Ingo Mar 12 at 11:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.