3

I am using a Raspberry Pi 4 Model B as my desktop computer with Raspbian Buster installed and everything works great except that some videos on Youtube don't have any audio. If I download the video and play it with Totem, then I can hear the audio. Is there a package that I need to install in order to hear the audio in my browser? I am using firefox-esr.

Video properties in Totem Player

  • Apparently recent versions of Firefox won't work on ARM. You could try installing an ARM64 version, or one of the Firefox clones such as Palemoon/Basilisk. I'll check this out myself on the weekend, meanwhile you can try this old build of mine if you like. – Dmitry Grigoryev Mar 11 at 9:43
  • 1
    The audio worked within the Palemoon build that you linked to. I'll have to try an ARM64 version of Firefox and see if that works as well. I appreciate you checking this out. – Powersurge Mar 12 at 5:21
  • FIY, I have made a build palemoon-28.8.4 from github.com/MoonchildProductions/UXP (the Pale_Moon-release branch). Seems to play youtube just fine. Could you include a link to a video showing the problem? – Dmitry Grigoryev Mar 12 at 19:29
  • This is the video that I am using to test with and it worked fine with your Palemoon build: youtube.com/watch?v=Huqll4cGXiE – Powersurge Mar 12 at 22:46
1

I have just checked your test video and it works fine in the latest Pale Moon, with sound.

Pale Moon browser is a fork of Firefox which supports older Firefox addons (which Firefox dropped after version 52). It is slower than Chromium but requires significantly less RAM, so it can actually outperform Chromium on a system which is short on memory.

Pale Moon can be installed by following instruction here. For the latest Raspbian, the installation instructions are:

echo 'deb http://download.opensuse.org/repositories/home:/stevenpusser/Raspbian_10/ /' > /etc/apt/sources.list.d/home:stevenpusser.list
wget -nv https://download.opensuse.org/repositories/home:stevenpusser/Raspbian_10/Release.key -O Release.key
apt-key add - < Release.key
apt-get update
apt-get install palemoon
| improve this answer | |
  • Pale Moon works great. Thank you Dmitry! – Powersurge May 20 at 15:39
1

Try playing the downloaded file with Firefox using File->Open.

If doesn't work, check that you have the AAC codecs installed using ffmpeg -codecs.

If playing the local file does work, then, as outlined here you should start Firefox with MOZ_DISABLE_CONTENT_SANDBOX=1 env variable, or whitelist the directory where the codec libraries are located in, e.g. security.sandbox.content.read_path_whitelist=/usr/local/lib/.

Also note that on Raspbian Chromium seems to have better support than Firefox. Apparently, the Firefox ESR build currently available in Raspbian supports none of the settings that are discussed above. So the only option is to use an alternative build of Firefox or a different browser.

| improve this answer | |
  • 1
    Hi Dmitry. Thank you for your response to my question. I tried your suggestions and this was the results: $ ffmpeg -codecs | egrep -i "aac|264" libavutil 56. 22.100 / 56. 22.100 libavcodec 58. 35.100 / 58. 35.100 libavformat 58. 20.100 / 58. 20.100 libavdevice 58. 5.100 / 58. 5.100 libavfilter 7. 40.101 / 7. 40.101 libavresample 4. 0. 0 / 4. 0. 0 libswscale 5. 3.100 / 5. 3.100 libswresample 3. 3.100 / 3. 3.100 libpostproc 55. 3.100 / 55. 3.100 – Powersurge Mar 11 at 6:09
  • 2
    DEV.LS h264 H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10 (decoders: h264 h264_v4l2m2m h264_mmal ) (encoders: libx264 libx264rgb h264_omx h264_v4l2m2m h264_vaapi ) DEA.L. aac AAC (Advanced Audio Coding) (decoders: aac aac_fixed ) D.A.L. aac_latm AAC LATM (Advanced Audio Coding LATM syntax) $ MOZ_DISABLE_CONTENT_SANDBOX=1 firefox <--- Still no audio security.sandbox.content.read_path_whitelist <--- Entry not found in about:config – Powersurge Mar 11 at 6:09
  • 2
    I do hear audio when using File->Open in firefox, btw. – Powersurge Mar 11 at 6:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.