1

I am a beginner with Pi. I got a Pi4 with 4GB ram and Rasbian Full Desktop installed, SenseHAT attached as well. I did the wpa_wifi config file and it works fine, will connect to WIFI with Monitor attached.

When I try to boot Pi4 without HDMI monitor plugged in, the RED power light and SenseHAT board is on but it won't boot. When I mean it won't boot, I mean the Pi can't connect to a network and I couldn't ssh into it via another PC on the same network.

If I boot first and then immediately plug HDMI in 1 second later, it still won't boot.

If I boot with monitor ALREADY plugged in, it works fine, WIFI will connect automatically, can ssh, even I unplug it later, it still stays good.

Also when my Pi successfully boots with monitor, the SenseHAT board will switch off blank which means it's booted. When I boot without HDMI monitor, SenseHAT stays on colourful led lighting which means it didn't boot....

So my conclusion is that it won't boot without HDMI cable connected to a monitor.

Because I am trying to make headless ssh connection available when I am outside.

Anyone can help?

  • 2
    You asked the same Question on www.raspberrypi.org/forums - failed to answer most of the questions and have included inadequate info. – Milliways Mar 14 at 4:16
  • okay,thank you. – Yitasha Mar 27 at 15:22
1

You have provided no meaningful information which would allow anyone to provide a definitive answer (and no actual evidence of any problem).

The most likely scenario is that the Pi has booted, but you have asked it to do the impossible i.e. boot to Desktop when there is no default Desktop (an examination of the boot logs would probably confirm this). See Pi4 Boot Problems Sticky

You have 2 options:-

  1. Boot to console.
  2. Force HDMI
    # uncomment if hdmi display is not detected and composite is being output
    hdmi_force_hotplug=1

The latter probably requires a default resolution to be set in raspi-config (at least on the Pi4 - earlier models defaulted to VGA resolution).

If you are not planning to use VNC the first is preferable - you can always start GUI manually with startx when required if a monitor is attached.

My Pi boot headless with or without monitor.

| improve this answer | |
1

This in fact is a known problem with the Sense-Hat. See https://github.com/astro-pi/python-sense-hat/issues/96 for detail.

Apparently, the Sense-Hat interferes with the resolution auto-detection if there is no monitor attached (works fine with monitor attached).

The work around is to manually specify a resolution (you do not have to force HDMI). You can do that with:

sudo raspi-config -> Advanced Options -> Resolution

Pick any of the DMT modes you like, just not default. If you attach a monitor from time to time, pick the DMT mode appropriate for your monitor. If you fly headless all the time, it matters not.

This issue has been open for a while and with is being specific to Sense-Hat and with a reasonable workaround, I doubt it will get fixed any time soon.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.