2

I have a raspberry pi 4, which I set up as accesspoint (bridge).

I performed an apt update and apt upgrade. That process did not indicate any problem. I'm now on raspbian buster.

After a reboot, I'm no longer able to access the internet from the raspberry, though the bridging itself is working (I can connect with my phone to the raspberry to go on the internet)

When trying to use the browser on the raspberry, I get the error: err_name_resolution_failed

When doing ping www.google.be or ping www.google.be -I br0, I get "Temporary failure in name resolution"

Edit: Ping 172.217.12.142 results in network unreachable.
Ping 172.217.12.142 -I br0 in all packets lost

Some more details:

$ ifconfig

        inet6 fe80::dea6:32ff:fe53:46ef  prefixlen 64  scopeid 0x20<link>
        ether dc:a6:32:53:46:ef  txqueuelen 1000  (Ethernet)
        RX packets 268  bytes 69413 (67.7 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 15  bytes 2052 (2.0 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether dc:a6:32:53:46:ef  txqueuelen 1000  (Ethernet)
        RX packets 634  bytes 353998 (345.7 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 388  bytes 49293 (48.1 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 9  bytes 524 (524.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 9  bytes 524 (524.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether dc:a6:32:53:46:f0  txqueuelen 1000  (Ethernet)
        RX packets 387  bytes 43643 (42.6 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 651  bytes 371960 (363.2 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

$ ip addr

    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br0 state UP group default qlen 1000
    link/ether dc:a6:32:53:46:ef brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master br0 state UP group default qlen 1000
    link/ether dc:a6:32:53:46:f0 brd ff:ff:ff:ff:ff:ff
4: br0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether dc:a6:32:53:46:ef brd ff:ff:ff:ff:ff:ff
    inet6 fe80::dea6:32ff:fe53:46ef/64 scope link 
       valid_lft forever preferred_lft forever

$ brctl show

br0     8000.dca6325346ef   no      eth0
                            wlan0

$ brctl showstp br0

 bridge id      8000.dca6325346ef
 designated root    8000.dca6325346ef
 root port         0            path cost          0
 max age          20.00         bridge max age        20.00
 hello time        2.00         bridge hello time      2.00
 forward delay        15.00         bridge forward delay      15.00
 ageing time         300.00
 hello timer           0.00         tcn timer          0.00
 topology change timer     0.00         gc timer         269.82
 flags      


eth0 (1)
 port id        8001            state            forwarding
 designated root    8000.dca6325346ef   path cost          4
 designated bridge  8000.dca6325346ef   message age timer      0.00
 designated port    8001            forward delay timer    0.00
 designated cost       0            hold timer         0.00
 flags          

wlan0 (2)
 port id        8002            state            forwarding
 designated root    8000.dca6325346ef   path cost        100
 designated bridge  8000.dca6325346ef   message age timer      0.00
 designated port    8002            forward delay timer    0.00
 designated cost       0            hold timer         0.00
 flags  

$ cat /etc/network/interfaces


# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

# Bridge setup 
auto br0
iface br0 inet manual
bridge_ports eth0 wlan0
wireless-power off

/etc/sysctl.conf

 all is commented

$ sudo nano /etc/dhcpcd.conf (I took some snippets)

# Inform the DHCP server of our hostname for DDNS.
hostname

# Use the hardware address of the interface for the Client ID.
clientid

# Persist interface configuration when dhcpcd exits.
persistent

# Rapid commit support.
# Safe to enable by default because it requires the equivalent option set
# on the server to actually work.
option rapid_commit


# Safe to enable by default because it requires the equivalent option set
# on the server to actually work.
option rapid_commit

# A list of options to request from the DHCP server.
option domain_name_servers, domain_name, domain_search, host_name
option classless_static_routes
# Respect the network MTU. This is applied to DHCP routes.
option interface_mtu

# A ServerID is required by RFC2131.
require dhcp_server_identifier

#list of options to request from the DHCP server.
option domain_name_servers, domain_name, domain_search, host_name
option classless_static_routes

# Respect the network MTU. This is applied to DHCP routes.
option interface_mtu

# A ServerID is required by RFC2131.
require dhcp_server_identifier

# Generate SLAAC address using the Hardware Address of the interface
#slaac hwaddr OR generate Stable Private IPv6 Addresses based from the DUID
slaac private

# For wireless Access point
denyinterfaces wlan0 eth0
1
  • "I'm now on raspbian buster.": do you upgraded fro stretch with modifications in /etc/apt/sources.list`?
    – Ingo
    Mar 15 '20 at 14:32
1

This is often a problem when upgrading your pi. Try to restart, and if it doesn't help, try to ping 172.217.12.142(IP of google.com), and give us results

Edit: post result of:

ifconfig

Probable solution: I can't see any IPv4 in ifconfig, so it probably doesn't exist, which means you cannot connect to server with IPv4

3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.