I am trying to image Ubuntu onto an SD card on my Mac for use with my Raspberry Pi 4 using thew new official imager tool from Raspberry Pi (found here: https://www.raspberrypi.org/downloads/). For whatever reason, every time I try to image any version of Ubuntu that is pre-selected from the Ubuntu OS Menu (v18.04.4 32 & 64 bit, v19.10.1 32 & 64 bit, and Ubuntu Core 18 32 & 64 bit), it completes the install, but at the verify stage it fails once it reaches 100%. Specifically, the error message reads "Verifying write failed. Contents of SD card is different then(than?)what was written to it." I know that the imager does work. I got it to install Raspbian without issue.

Moreover, I have tried downloading the .xz file directly from Ubuntu (v18.04.4 LTS - https://ubuntu.com/download/raspberry-pi) and using the RPi imager with that file. It gives the same error message. I have also tried unzipping the file and using the .img file with the imager and it gives a different error saying Error writing file to disk.

So, the question is why won't it install Ubuntu? Since this installer is under 2 weeks old, I have not found much information elsewhere.

The steps I have taken:

  1. Download the imager from RPi (https://www.raspberrypi.org/downloads/)
  2. Erase and format SD card from imager option
  3. Select a version of Ubuntu from the OS menu, select SD card, select Write
  4. Imager writes 100% of the way, verifies up to 100% and then fails.
  5. Repeat steps 2-4 for all versions of Ubuntu with no luck.

Below is the error that pops up. Verify Fail Message

A successful install message (in the case of Raspbian, for example) should look like this: Successful Install Message

If there is any more useful information I can provide, please let me know.

  • 1
    Not an answer to why the Raspberry Pi Imager won't work, but try balenaEtcher. If Etcher works, then the problem is likely with the new software; if not, then there's some other problem.
    – Bob Brown
    Commented Mar 15, 2020 at 17:26
  • FWIW I saw the same behavior with multiple cards and attempts. Commented Mar 15, 2020 at 18:22
  • 1
    @BobBrown I took you advice. Etcher worked beautifully. So, I got what I wanted (a working Ubuntu on my RPi4), but the problem still persists.
    – Lou
    Commented Mar 17, 2020 at 21:58
  • Thanks for the feedback and the kind word. That suggests a problem with the Raspberry Pi Imager, not really surprising with new software. (Etcher is your friend.)
    – Bob Brown
    Commented Mar 18, 2020 at 2:45

4 Answers 4


I find the Raspberry Pi Imager fails to verify about 20% of the time. I have no explanation as to why but repeating the process with the same SD card and balenaEtcher produces a working install. I usually flash large (128GB) cards which may or may not be a factor.


I have never used a Linux system before and have never even taken a computer class so bear with me. I got this to work so you should be able to as well. I grabbed a couple of the Pi 4's, the 4GB and 8GB models and downloaded Kali Linux on my laptop. Here is what I did to get it to work.

  1. On the Linux system:

    sudo apt if not in root (enter root by sudo su or sudo -i):

    apt install gparted
  2. Once done open gparted it will prompt you to enter your password every time.

  3. Important there is a drop down menu in the top right corner; make sure you change the desired drive to your SD card. It will be set on your OS drive by default!

  4. Right click on each partition on the SD card and delete it. Then click the green check mark, it will prompt you it will overwrite, click apply.

  5. Now up top in the menu bar click device/create partition table. By default it is set as msdos; change this to mac and apply.

  6. Highlight unallocated drive and right click new.

  7. Now change the "File system" (default ext4) to fat32. Label the file system ubuntu (or whatever) and click ADD.

  8. Click the green check mark again to apply.

  9. The SD card should be formatted properly at this point.

  10. Use the Raspberry Pi imager and select ubuntu 64bit--sd card--write. It should verify after writing.

So far I haven't got this to work on the 8GB model. Nothing displays on the monitor yet, I'm still working on a solution. It may not work at all without NOOBS. with NOOBS on the 8GB model you must push the 2 button to get the display to show on the screen. So, I don't know if there is a way to do it with this. If anyone does know please share as I've been stuck for three days try to figure this out. (Kali Linux doesn't work on the 8GB model according to what I have found online).

Also it is important to note that Kubuntu is not compatible and has multiple fails. I have got it to load without failure but the desktop never loads after a reboot. (I had to repeat this process for new desktop install attempts with multiple fails). I used Xubuntu after that and had "Great Success!" after rebooting. The desktop launched and is running! However it does seem a little slow.

UPDATE it seems for some reason the imager wont verify on the pi itself i am only having success when i run these operation on my laptop using kali linux and the raspberry pi imager. i was also successful with kali linux os on the pi 4g using this process as well as ubuntu mate.

  • Fortunately after dealing with partitions image was written successfully
    – A.Ametov
    Commented Mar 15, 2021 at 10:12
  • similarly adding an all-default primary partition in fdisk also solved my problem
    – Piotr
    Commented Nov 17, 2023 at 20:38

Make sure on the Pi 4 that you use the HDMI output that’s closest to the USB C. That’s the primary. I had a bunk SD card the other day. I noticed that with Etcher you can set up to install from USB also just in case.


Try other PC once, please.

In my case, always failed to verify with my desktop (Win10 pro, 64 bit), but no problem on my notebook (Win 10 pro, 64 bit).

I suspect that this problem is related with SD card reader driver.

Not the answer you're looking for? Browse other questions tagged or ask your own question.