I have tried googling for this to see if people have similar issues but found nothing.

I recently obtained a Raspberry Pi 4 (2gb), installed raspbian lite earlier today which all worked just fine, but I was really interested in setting up a 64-bit OS instead, I upgraded the kernel and was able to run/install things using chroot but since I would prefer having full 64-bit to be able to run systemd services through it, I was looking for an alternative.

I found out the Ubuntu server now has images for raspberry pi, including 64-bit ones, so I rushed over to their download page (https://ubuntu.com/download/raspberry-pi) and downloaded 18.04.4 LTS (64-bit) for the RPi 4.

Attempting to install it using the Raspberry Pi Imager tool (I previously used for the raspbian image) everything from writing/verifying seems to happen at the right time duration, but in the end it will tell me the data on the sd card does not match what was written to it.

I gave it multiple attempts, and even tried multiple images (18.04.4 LTS as well as 19.10 (both 64-bit) and 18.04 32-bit version) all of them gave me the same result.

Playing around in the RPi Imager, I noticed there are also default options in there for installing the Ubuntu server, so I attempted using that option instead, but I was unlucky again as it gave me the same result.

Looking at the Ubuntu installation page, they are using Win32DiskImager so I figured I would give that a shot. The same thing happens (it instantly fails verification in "sector 2048").

Afraid somehow the SD-card or my adapter broke in the meantime, I figured I would try writing Raspbian Lite to it once more, and success! So this means it has to be the image file right? It's a 16gb Samsung SD card if that helps.

I am clueless on how to proceed, and as I said before can't find anyone encountering similar issues

  • searched and found raspberrypi.stackexchange.com/questions/109320/… - first comment suggests using BalenaEtcher instead - Rpi's imager is pointless, since you have to download the image every single time you want to burn it! Mar 17, 2020 at 0:04
  • buy a new SD Card!
    – Milliways
    Mar 17, 2020 at 0:22
  • @JaromandaX you don't have to download every time it does cache the download and will only redownload if a newer version is available. Mar 17, 2020 at 6:46
  • OK, to be honest, I haven't found where that download is cached, and I've only used it once :p Mar 17, 2020 at 8:48
  • I also downloaded the image file manually and attempted to burn that to avoid that problem :D @Milliways that hardly seems to be the problem, it is fairly new and why would raspbian work perfectly fine?
    – Alex
    Mar 17, 2020 at 21:40

1 Answer 1


Use BalenaEtcher instead of Raspberry Pi Imager / Win32DiskImager

(As Jaromanda X's comment pointed out)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.