0

My issue is with Lightdm, it will not autostart, keeps going to CLI. From there I can type startx and it works fine. I have run raspi-config to set boot straight to desktop, seems to have been ignored. I have also ran "sudo dpkg-reconfigure lightdm".

I'm pretty new at this so I have no idea where to look. I'd like to have systemctl handling this as it was supposed to.

3
  • 1
    Welcome. Edit in the output from systemctl get-default and systemctl status lightdm.
    – goldilocks
    Mar 17, 2020 at 12:04
  • Right, that gave me something to look. The first one says graphical.target. The second one had: ● lightdm.service - Light Display Manager Loaded: loaded (/lib/systemd/system/lightdm.service; indirect; vendor preset: enabled) Active: failed (Result: exit-code) since Wed 2020-03-18 00:31:57 WET; 12min ago Docs: man:lightdm(1) Process: 674 ExecStartPre=/bin/sh -c [ "$(cat /etc/X11/default-display-manager 2>/dev/null)" = "/usr/sbin/lightdm" ] (code=exited, status=1/FAILURE)
    – C0pterPi
    Mar 18, 2020 at 0:46
  • and lightdm.service: Start request repeated too quickly.
    – C0pterPi
    Mar 18, 2020 at 0:53

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.