2

I'm trying to forget an SSID from a new Raspberry Pi 4. I need to get it connected to a hidden network in our house, but it grabbed a public guest network first by default, and now I can't get it to go away. I turn off the wifi, edit /etc/wpa_supplicant/wpa_supplicant.conf (yes, as sudo) to remove the existing network reference. Save it, close it, re-open it to confirm that the network has been removed. Turn on wifi, it immediately grabs the same wifi name and reinserts the entry back into wpa_supplicant.

If I erase bad_public from wpa_supplicant and put in good_hidden SSID, it still won't grab it--defaults to bad_public and inserts the record. It sure seems like there's some other place where the record is getting cached and it keeps reconnecting. Thanks for your help.

EDIT to add: Running Raspbian from NOOBS 3.3.1

| improve this question | | | | |
1

NOOBS has to access networking and has its own mechanism, independent of Raspbian.

Normally it re-configures Raspbian on installation. It may be overwriting the Raspbian settings.

Unfortunately you are unlikely to get help on NOOBS on this site because most experienced users don't use it.

I suggest you reboot the the NOOBS setup and try disabling there.

PS reading a file after changing it DOES NOT prove it has been written to the SD Card - it may be cached, but should be written if properly shutdown.

| improve this answer | | | | |
  • 1
    basically, NOOBS causes more issues (for newbies) than it solves – Jaromanda X Mar 18 at 22:41
1

I replaced the out-of-the-box NOOBS card with a pure Raspbian install. Worked just fine. Yay Raspbian, Boo NOOBS!

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.