I have a Raspberry Pi 4 and I would like to set it up so that I can use my Netflix subscription to watch on the TV it's hooked up to.

I've seen that OSMC has support for Netflix but that it's currently limited to Raspberry Pi 3 and older models.

Is there an alternative that I can use to watch Netflix on my Raspberry Pi 4?

I've also seen posts about a Netflix plugin for Kodi that might be used on Raspberry Pi 4 when running LibreELEC. Is that a viable option?


3 Answers 3


AFAIK it's possible to get Netflix working in Chromium in Raspbian OS, if you manage to rip the DRM library out of ChromeOS. I haven't tried it myself, but this user seems to have succeeded on a Pi 3. I don't see why Pi 4 would be different.

  • I don't see why Pi 4 would be different. OP uses OSMC and that does not yet support the Pi4. That's why that solution is limited to Pi3-
    – Dirk
    Mar 18, 2020 at 23:29
  • 2
    @Dirk I'm talking about running Chromium on Raspbian, not OSMC. Mar 19, 2020 at 8:15

I've created a 1-line-paste solution to this, in case it's helpful for anyone:


It essentially comes down to:

1.) Having the latest Raspbian installed 2.) Running:

curl -fsSL https://pi.vpetkov.net -o ventz-media-pi
sh ventz-media-pi

3.) Rebooting and then going to the Application Menu (top left) -> go to “Internet” -> open “Chromium (Media Edition)”


  • This. Is. Awesome. (works great on my pi4)
    – Botspot
    May 12, 2020 at 16:47
  • @Ventz I tried to install it on my Raspberry Pi 4 (8 GB) with Ubuntu Mate 20.10 and although I see the Media Edition installed, it doesn't seem to work, I'm still getting an error message from Netflix
    – Roy Ash
    Nov 7, 2020 at 0:01
  • I’ve only tested it on Raspian (Raspberry Pi OS). It does not work on 64bit (due to Google - both Chromium and libwidevine are 32bit only for arm). You may be able to manually “port” for Ubuntu on the Pi, but I haven’t tried it. It should be easy to check- drop latest lib and launch Chromium with the correct user agent from the ventz-media-pi scripts.
    – Ventz
    Nov 8, 2020 at 3:22

I've been able to watch Netflix quite nicely on my Raspberry Pi 4 by installing LibreELEC OS OS (Leia 9.2.1) on it and adding the CastagnalIT Netflix plugin for Kodi on top of that.

If I understand correctly, the plug-in is indeed based on the technique that @dmitry-grigoryev mentions in his answer.

  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year.
    – Ingo
    May 17, 2020 at 16:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.