1

enter image description here

I have a Raspberry Pi 4 since a few days and I've been trying to boot it with Linux Ubuntu since then.

But it just stops booting every time I try it. The last thing which is displayed is [341.992834] mmcblk0: p1 p2

I also adjusted a screenshot with what I am seeing right now.

The Image is the Ubuntu version 18.04.4 LTS. My SD card is the "Intenso Micro SD (32GB, Class 10)"

Does anyone have an idea why this is happening?

3
  • 1
    Nothing against Ubuntu, but maybe it would be wiser to use Raspbian if this is your first rodeo. – goldilocks Mar 20 '20 at 21:51
  • unfortunately I need Ubuntu – WhySoToxic Mar 20 '20 at 21:54
  • Ok, I'm going to install Raspbian now – WhySoToxic Mar 20 '20 at 22:35
2

It looks like there is a problem the either the SC card or the Ubutu image on the SD card.

Toward the top of your error messages there seems to be an issue with the card "Card stuck in wrong state!" message. Further on down the boot process is trying to mount the filesystems to boot Ubuntu e.g. at "mounting /dev/mmcbjk0p2 on /root failed". Having failed to mount the /root filesystem it can't boot.

I would suggest you try the latest version of Raspbian on a new SD card and check it boots OK. Then you could try reimaging Ubuntu onto the new working card and see how you go from there having eliminated potential hardware issues.

1
  • I tried Raspbian on the same Card and it worked perfect – WhySoToxic Mar 23 '20 at 14:43
2

I had the same problem and I think I know why: On the download page the list of supported models does not include the Pi 4. I‘m using Raspbian (10/Buster) instead and having no problems. Do you need Ubuntu, or are other Debian-based distros also OK?

2
  • I see Raspberry Pi 4 on their page – WhySoToxic Mar 23 '20 at 14:43
  • I was looking on the Ubuntu MATE page, sorry for that! Can you please explain why you need Ubuntu? Maybe I know how to do that thing on Raspbian. – HimbeerserverDE Mar 24 '20 at 8:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.