0

I am running my Pi 4 headless using VNC. Everything works as expected, however when I reboot the Pi, VNC does not reconnect unless I physically connect a monitor directly to the HDMI port on the Pi. After that all is good and I can disconnect the monitor from the Pi.

  • How do you connect with VNC? Do you use the IP address or host name? – SkyPlayX Mar 21 at 15:16
  • Connecting using the IP address Pradhyumna – Clive Mar 22 at 14:07
  • Is it a static or dynamic one? – SkyPlayX Mar 22 at 14:49
  • Static, IP remains the same for the Pi4? – Clive Mar 23 at 15:06
1

If you want to run without a monitor you need to create a DISPLAY

See https://raspberrypi.stackexchange.com/a/109282/8697

Alternatively you can you can create a Virtual Desktop
See https://raspberrypi.stackexchange.com/a/106627/8697

| improve this answer | |
  • 1
    Great thanks for the help, this was sorted... So with default settings and no monitor attached, VNC will NOT work, as the booted RPI4 will not have a video output system that can be used by VNC. Adding hdmi_force_hotplug=1 to /boot/config.txt solves the problem. The Pi4 running headless, will now be able to be accessed via VNC. – Clive Mar 22 at 14:19
  • 1
    Then please add your own answer and select the green tick mark. – SkyPlayX Mar 22 at 14:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.