1

This Rpi2 has Python 3.4 working - the DAQC2 piplate software install requires 3.5. I can't identify the latest version applicable or find it at Python.org with wget. Alternately, Is there a pre-compiled version available? The Rpi documentation is thorough regarding Python packages, I'm not getting it for updating the Python version itself.

Is there any reason Python 3.5 would not work with an Rpi2? Reason I ask is I have 3.5 working on a Rpi3.

Thanks.

1

Don't bother! You CAN install from source, but it is a lot of effort.

AFAIK Raspbian hasn't had Python 3.4 since Jessie which is obsolete. There would be lots of other superseded programs as well.

"I have 3.5 working on a Rpi3" - again you are using an old OS.

Do a fresh install of Raspbian-Buster - you only have to do this every 2 years!

1

You're probably using Raspbian Jessie (?). That will not get a later version of Python.

Install Raspbian Buster and you will get Python 3.7

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.