1

My setup PI 3B+ OS : Raspian

Trying to connect the pi headless using my laptop. Both Pi and Laptop are connected to same wireless router.

Added the below config in wpa_supplicant.conf with correct credentials

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=<Insert country code here>

network={
 ssid="<Name of your WiFi>"
 psk="<Password for your WiFi>"
}

Also added ssh file to boot folder fo SD card.

On bootup can see Pi is connected to Wifi, router lists the Pi with IP address(192.168.0.101) When I try to ping the Pi from Laptop using this IP, get below error

Pinging 192.168.0.101 with 32 bytes of data:
Reply from 192.168.0.104: Destination host unreachable.

please help in setting the Pi in headless mode correctly. Thanks

5
0

Thanks guys for the comments.

I got a clue from Ingo's comment. Issue was with the router configuration which was blocking clients to ping each other. Changed the router config and am able to ssh to my pi board

Special thanks to Ingo :) cheers :)

1
  • That security setting on the router was exactly my guess :-) – Ingo Mar 26 '20 at 9:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.