1

I've been trying to set up my Raspberry Pi 0W V1.3 headless. I only have the possibility of connecting a monitor, but no keyboard/mouse.

I downloaded a fresh version of Raspbian Buster lite (Release: 2020-02-13) from the official site and flashed it to my SD card. I created a wpa_supplicant.conf file with unix line endings and with the following content:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=FI

network={
     ssid="*SSID*"
     psk="*PASSWORD*"
     key_mgmt=WPA-PSK
}

I have also tried windows line endings and multiple versions of the wpa supplicant. Some of the versions I've tried include leaving the country field away, adding scan_ssid=1, leaving key_mgmt field away and different combinations of these.

I also added the empty ssh file to enable ssh. When I boot up the system, I get no errors on the boot screen, yet for some reason it doesn't connect to my wireless network. I logged in to my routers control panel to see connected devices and it's not there. There's no restrictions on the network that would affect the pi. The SSID is not hidden nor contains any special characters that could induce this problem. When I re-insert the SD card to my computer and see the wpa_supplicant.conf and ssh files gone as they should be. According to my knowledge and multiple different tutorials online, I should be doing everything correctly, yet I get no connection.

Any ideas on what possibly causes this?

  • How do you realize that it doesn't connect to the wireless network? Normally on the boot up screen you see what ip address the RasPi has got. Do you see an ip address? – Ingo Mar 24 at 11:58
  • @Ingo I logged in to my routers control panel to see connected devices and it's not there. – Sanduuz Mar 24 at 12:20
  • You could configure an access point on the RasPi, so you can determine if WiFi works and you can login by ssh. But I have no idea how it help you to connect to your router. Do you have another computer/laptop with Linux available? – Ingo Mar 24 at 13:13
  • @Ingo I'm pretty sure the WiFi works on the pi, because it's a brand new pi and I haven't used it at all. Also I do have another computer with linux available. – Sanduuz Mar 24 at 13:23
  • If everything works with the RasPi then the problem is the router. – Ingo Mar 24 at 13:38
2

A few thoughts:

Is you SSID hidden? If so, add scan_ssid=1 one a new line just after the SSID line Make sure the file has only line feeds at the end - no carriage returns You may have a keyboard / language issue. From memory the default until reset is UK English and any other characters used to generate the SSID or pass phrase can give issues. Spaces often give errors as well.

| improve this answer | |
  • Few clarifications: the SSID isn't hidden nor contains any special characters or spaces. Also the wpa supplicant doesn't have carriage returns so that's what I meant with unix line endings. – Sanduuz Mar 24 at 6:25
1

Everything seems to to be all right. The only possibility I see so far is to login to the RasPi and analyze what's wrong with the WiFi connection. So you should purchase a keyboard/mouse. You can also use a simple USB cable to connect the RasPi to your Linux computer and use the OTG gadget connection. Then you can ssh into the raspi. You may also consider to purchase a USB to TTL (RS232) serial cable to connect to the computer and get the serial debug console.

Then the first checks could be:

rpi ~$ sudo iw dev
rpi ~$ sudo iw dev wlan0 link
rpi ~$ systemctl status wpa_supplicant.service
rpi ~$ journalctl --unit=wpa_supplicant.service
| improve this answer | |
1

You could also set up the USB port for networking if you have a Mac or PC you can use - that would give you access via SSH to set up the Wifi using raspi-config.

Many tutorials on the net - e.g. one from a random Google

| improve this answer | |
  • That is exactly what I told to use the OTG gadget connection in my answer. It's the same. – Ingo Mar 24 at 15:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.