0

I am somewhat new to Linux and raspi's in general, so it would be helpful to keep answers simple and well-versed. I am trying to install a debian package on my raspi (raspbian), which is Cockatrice. I ran into the following error when trying to install it via the command line:

The following packages have unmet dependencies:
cockatrice:amd64 : Depends: libqt5multimedia5-plugins:amd64 but it is not installable
                Depends: libqt5svg5:amd64 but it is not installable
                Depends: libc6:amd64 (>= 2.14) but it is not installable
                Depends: libgcc1:amd64 (>= 1:3.0) but it is not installable
                Depends: liblzma5:amd64 (>= 5.1.1alpha+20120614) but it is not installable
                Depends: libprotobuf17:amd64 but it is not installable
                Depends: libqt5concurrent5:amd64 (>= 5.0.2) but it is not installable
                Depends: libqt5core5a:amd64 (>= 5.11.0~rc1) but it is not installable
                Depends: libqt5gui5:amd64 (>= 5.11.0~rc1) but it is not installable
                Depends: libqt5multimedia5:amd64 (>= 5.6.0~beta) but it is not installable
                Depends: libqt5network5:amd64 (>= 5.0.2) but it is not installable
                Depends: libqt5printsupport5:amd64 (>= 5.0.2) but it is not installable
                Depends: libqt5sql5:amd64 (>= 5.0.2) but it is not installable
                Depends: libqt5svg5:amd64 (>= 5.6.0~beta) but it is not installable
                Depends: libqt5websockets5:amd64 (>= 5.6.0) but it is not installable
                Depends: libqt5widgets5:amd64 (>= 5.11.0~rc1) but it is not installable
                Depends: libstdc++6:amd64 (>= 5.2) but it is not installable
                Depends: zlib1g:amd64 (>= 1:1.1.4) but it is not installable

I tried running some commands to fix this error, but didn't seem to help:

sudo apt-get install -f

sudo apt --fix-broken install

I also tried installing the individual packages, and I just get a message saying that the module is already installed, and it's version seems to be above the needed one for Cockatrice.

sudo apt-get install libqt5svg5
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    libqt5svg5 is already the newest version (5.11.3-2).
    libqt5svg5 set to manually installed.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Could someone help me resolve these errors, or find a way to install the package?

  • What's that AMD64 junk? Your raspberry has an ARMHF processor, do NOT add debian repos for other architectures that won't work and may break your system beyond repair. – Dougie Mar 24 at 16:20
1

You are trying to install a package for a different processor architecture (AMD64) on the Pi (which is ARM). All the dependencies you see are AMD64 libraries. Because they are for a different processor, they will not run on the Pi. That is the reason why these dependencies are not in the repository for the Pi, and that they are not installable.

I have tried to find a Pi-version of the Cockatrice package, but I have not been able to. You might try to install from source, but there have been some issues there as well; one of them is the expected compile time.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.